uClibc: use position independent code for crt1, slightly reduces size of all executables
authorFelix Fietkau <nbd@openwrt.org>
Sun, 30 Jun 2013 07:54:51 +0000 (07:54 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 30 Jun 2013 07:54:51 +0000 (07:54 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 37096

toolchain/uClibc/patches-0.9.33.2/210-mips_use_pic_crt1.patch [new file with mode: 0644]

diff --git a/toolchain/uClibc/patches-0.9.33.2/210-mips_use_pic_crt1.patch b/toolchain/uClibc/patches-0.9.33.2/210-mips_use_pic_crt1.patch
new file mode 100644 (file)
index 0000000..2ca10d4
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/libc/sysdeps/linux/mips/Makefile.arch
++++ b/libc/sysdeps/linux/mips/Makefile.arch
+@@ -20,6 +20,8 @@ ifneq ($(UCLIBC_HAS_THREADS_NATIVE),y)
+ SSRC += vfork.S clone.S
+ endif
++CFLAGS-crt1.S += $(PICFLAG)
++
+ ASFLAGS-syscall_error.S += -D_LIBC_REENTRANT
+ ARCH_HEADERS := sgidefs.h