[packages_10.03.2] srelay: merge r29066
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 5 Feb 2012 16:11:41 +0000 (16:11 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 5 Feb 2012 16:11:41 +0000 (16:11 +0000)
SVN-Revision: 30262

net/srelay/Makefile
net/srelay/files/srelay.init

index 7a8cb4233b80713180b0820cff9c364c7026c1c5..d579d1d5063b663b2e30bcdce3c88f8892ea4707 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=srelay
 PKG_VERSION:=0.4.8b3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/socks-relay
index 6d2343888ef1d6d7073de72df71771b81ec71d05..95d1d8137619eec6dc5821981d2329e2cf68ab2e 100644 (file)
@@ -1,13 +1,14 @@
 #!/bin/sh /etc/rc.common
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
+
 START=50
 
+SERVICE_USE_PID=1
+
 start() {
-       if [ -f /etc/srelay.conf ];then
-               srelay -c /etc/srelay.conf -r -s 
-       fi
+       service_start /usr/bin/srelay -c /etc/srelay.conf -r -s 
 }
 
 stop() {
-       killall srelay
+       service_stop /usr/bin/srelay
 }