Add openrrcp (#3206)
authorFlorian Fainelli <florian@openwrt.org>
Fri, 7 Mar 2008 11:04:02 +0000 (11:04 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Fri, 7 Mar 2008 11:04:02 +0000 (11:04 +0000)
SVN-Revision: 10560

net/openrrcp/Makefile [new file with mode: 0644]

diff --git a/net/openrrcp/Makefile b/net/openrrcp/Makefile
new file mode 100644 (file)
index 0000000..c51bb25
--- /dev/null
@@ -0,0 +1,46 @@
+# 
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id: $
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=openrrcp
+PKG_VERSION:=0.2.1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://nording.ru/projects/download/openrrcp/stable
+PKG_MD5SUM:=e3d6097732af812b03dbbbedeced34d2
+PKG_CAT:=zcat
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/openrrcp
+  SECTION:=net
+  CATEGORY:=Network
+  TITLE:=OpenRRCP toolset for managing RRCP-capable Ethernet switches
+  URL:=http://openrrcp.org.ru/
+endef
+
+define Package/openrrcp/description
+       OpenRRCP toolset for managing RRCP-capable Ethernet switches
+endef
+
+define Build/Compile
+       $(call Build/Compile/Default, \
+               PREFIX="/usr" \
+       )
+endef
+
+define Package/openrrcp/install
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(1)" \
+               PREFIX="/usr" \
+               install
+endef
+
+$(eval $(call BuildPackage,openrrcp))