create a platform config-* file if there is none already when running kernel_menuconf...
authorFelix Fietkau <nbd@openwrt.org>
Fri, 13 Jun 2008 15:28:31 +0000 (15:28 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 13 Jun 2008 15:28:31 +0000 (15:28 +0000)
SVN-Revision: 11460

include/.target.mk.swp [new file with mode: 0644]
include/kernel-build.mk
include/target.mk

diff --git a/include/.target.mk.swp b/include/.target.mk.swp
new file mode 100644 (file)
index 0000000..d41d2cc
Binary files /dev/null and b/include/.target.mk.swp differ
index 75c2bcf01aacbedcd5699638c5836db28c9037b3..b6d2cf5efbb6ee27274d8cb42b15f8b75516a1e7 100644 (file)
@@ -77,6 +77,7 @@ define BuildKernel
        $(MAKE) -C image compile TARGET_BUILD=
 
   oldconfig menuconfig: $(STAMP_PREPARED) FORCE
+       [ -e "$(LINUX_CONFIG)" ] || touch "$(LINUX_CONFIG)"
        $(LINUX_CONFCMD) > $(LINUX_DIR)/.config
        touch $(LINUX_CONFIG)
        $(MAKE) -C $(LINUX_DIR) $(KERNEL_MAKEOPTS) $$@
index be9f128cda2993f54aa84e6cf95f06d972fb912f..8b123959d32cf8061fc863248ed9519f349d6e0f 100644 (file)
@@ -109,7 +109,7 @@ GENERIC_PATCH_DIR := $(GENERIC_PLATFORM_DIR)/patches$(shell [ -d "$(GENERIC_PLAT
 GENERIC_FILES_DIR := $(GENERIC_PLATFORM_DIR)/files$(shell [ -d "$(GENERIC_PLATFORM_DIR)/files-$(KERNEL_PATCHVER)" ] && printf -- "-$(KERNEL_PATCHVER)" || true )
 
 GENERIC_LINUX_CONFIG?=$(firstword $(wildcard $(GENERIC_PLATFORM_DIR)/config-$(KERNEL_PATCHVER) $(GENERIC_PLATFORM_DIR)/config-default))
-LINUX_CONFIG?=$(firstword $(wildcard $(foreach subdir,$(PLATFORM_DIR) $(PLATFORM_SUBDIR),$(subdir)/config-$(KERNEL_PATCHVER) $(subdir)/config-default)))
+LINUX_CONFIG?=$(firstword $(wildcard $(foreach subdir,$(PLATFORM_DIR) $(PLATFORM_SUBDIR),$(subdir)/config-$(KERNEL_PATCHVER) $(subdir)/config-default)) $(PLATFORM_DIR)/config-$(KERNEL_PATCHVER))
 LINUX_SUBCONFIG?=$(firstword $(wildcard $(PLATFORM_SUBDIR)/config-$(KERNEL_PATCHVER) $(PLATFORM_SUBDIR)/config-default))
 ifeq ($(LINUX_CONFIG),$(LINUX_SUBCONFIG))
   LINUX_SUBCONFIG:=