[package] strongswan4: add af-alg plugin
authorFlorian Fainelli <florian@openwrt.org>
Tue, 16 Aug 2011 20:34:22 +0000 (20:34 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Tue, 16 Aug 2011 20:34:22 +0000 (20:34 +0000)
* Add kernel crypto user-space interface plugin (strongswan4-mod-af-alg)
* Requires kmod-crypto-user

Signed-off-by: Lars Hjersted <lars@hjersted.com>
SVN-Revision: 28017

net/strongswan4/Makefile

index f3c708322c34f9f5011b0f145067015f3ab0054a..5c706b69ec850c3f6fb6087ce48a3b4ac9ae38f8 100644 (file)
@@ -17,6 +17,7 @@ PKG_MD5SUM:=ee7c50a90c91307b111e8085f2479890
 
 PKG_MOD_AVAILABLE:= \
        aes \
 
 PKG_MOD_AVAILABLE:= \
        aes \
+       af-alg \
        agent \
        attr \
        attr-sql \
        agent \
        attr \
        attr-sql \
@@ -133,6 +134,7 @@ $(call Package/strongswan4/Default)
        +strongswan4-app-pluto \
        +strongswan4-libfast \
        +strongswan4-mod-aes \
        +strongswan4-app-pluto \
        +strongswan4-libfast \
        +strongswan4-mod-aes \
+       +strongswan4-mod-af-alg \
        +strongswan4-mod-agent \
        +strongswan4-mod-attr \
        +strongswan4-mod-attr-sql \
        +strongswan4-mod-agent \
        +strongswan4-mod-attr \
        +strongswan4-mod-attr-sql \
@@ -444,6 +446,7 @@ $(eval $(call BuildPackage,strongswan4-utils))
 
 $(eval $(call BuildPlugin,aes,AES crypto,))
 $(eval $(call BuildPlugin,agent,SSH agent signing,))
 
 $(eval $(call BuildPlugin,aes,AES crypto,))
 $(eval $(call BuildPlugin,agent,SSH agent signing,))
+$(eval $(call BuildPlugin,af-alg,AF_ALG Linux crypto API,+kmod-crypto-user))
 $(eval $(call BuildPlugin,attr,File-based config attr,))
 $(eval $(call BuildPlugin,attr-sql,SQL-based config attrib,+strongswan4-mod-sql))
 $(eval $(call BuildPlugin,blowfish,Blowfish crypto,))
 $(eval $(call BuildPlugin,attr,File-based config attr,))
 $(eval $(call BuildPlugin,attr-sql,SQL-based config attrib,+strongswan4-mod-sql))
 $(eval $(call BuildPlugin,blowfish,Blowfish crypto,))