packages: update alsa-utils to 1.0.27.2
authorJonas Gorski <jogo@openwrt.org>
Sun, 4 Aug 2013 16:41:37 +0000 (16:41 +0000)
committerJonas Gorski <jogo@openwrt.org>
Sun, 4 Aug 2013 16:41:37 +0000 (16:41 +0000)
Signed-off-by: Peter Wagner <tripolar@gmx.at>
Signed-off-by: Jonas Gorski <jogo@openwrt.org>
SVN-Revision: 37690

utils/alsa-utils/Makefile
utils/alsa-utils/patches/100-uClibc-compat.patch

index f203ecb064fcad159e37aa33ccf53436327e0f53..f60da4ad6910064cb049ebe94bd123302b8b008e 100644 (file)
@@ -8,13 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=alsa-utils
-PKG_VERSION:=1.0.24.2
-PKG_RELEASE:=2
+PKG_VERSION:=1.0.27.2
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=ftp://ftp.alsa-project.org/pub/utils/ \
                http://alsa.cybermirror.org/utils/
-PKG_MD5SUM:=8238cd57cb301d1c36bcf0ecb59ce6b2
+PKG_MD5SUM:=b65e9a04181bd7c9db7667a4566f8dc3
 PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
index 976612591cff453df41e0f078ff1057d8db7c1cf..987c9b8b79a97f466e1249a14b37cd096a989211 100644 (file)
@@ -1,8 +1,6 @@
-Index: alsa-utils-1.0.24.2/alsamixer/volume_mapping.c
-===================================================================
---- alsa-utils-1.0.24.2.orig/alsamixer/volume_mapping.c        2011-03-11 13:26:29.000000000 +0100
-+++ alsa-utils-1.0.24.2/alsamixer/volume_mapping.c     2011-03-11 13:27:58.000000000 +0100
-@@ -109,9 +109,9 @@
+--- a/alsamixer/volume_mapping.c
++++ b/alsamixer/volume_mapping.c
+@@ -114,9 +114,9 @@ static double get_normalized_volume(snd_
        if (use_linear_dB_scale(min, max))
                return (value - min) / (double)(max - min);
  
@@ -14,7 +12,7 @@ Index: alsa-utils-1.0.24.2/alsamixer/volume_mapping.c
                normalized = (normalized - min_norm) / (1 - min_norm);
        }
  
-@@ -144,7 +144,7 @@
+@@ -149,7 +149,7 @@ static int set_normalized_volume(snd_mix
        }
  
        if (min != SND_CTL_TLV_DB_GAIN_MUTE) {