add missing pppoe-connect script (closes: #1603)
authorNicolas Thill <nico@openwrt.org>
Sat, 21 Apr 2007 21:00:34 +0000 (21:00 +0000)
committerNicolas Thill <nico@openwrt.org>
Sat, 21 Apr 2007 21:00:34 +0000 (21:00 +0000)
SVN-Revision: 7028

net/rp-pppoe/Makefile

index 55c02cefd017973a52f2a29baf1f16c54b516cd3..ab706b7eeb74a6b7178fc4b6e3487922167b2c24 100644 (file)
@@ -63,7 +63,8 @@ define Package/rp-pppoe-client/install
        $(INSTALL_DATA) $(PKG_INSTALL_DIR)/etc/ppp/pppoe.conf $(1)/etc/ppp/
        $(INSTALL_DIR) $(1)/usr/sbin
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/pppoe $(1)/usr/sbin/
        $(INSTALL_DATA) $(PKG_INSTALL_DIR)/etc/ppp/pppoe.conf $(1)/etc/ppp/
        $(INSTALL_DIR) $(1)/usr/sbin
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/pppoe $(1)/usr/sbin/
-       $(CP) $(PKG_BUILD_DIR)/scripts/pppoe-{start,stop} $(1)/usr/sbin/
+       $(CP) $(PKG_BUILD_DIR)/scripts/pppoe-{connect,start,stop} $(1)/usr/sbin/
+       $(SED) 's,modprobe,insmod,g' $(1)/usr/sbin/pppoe-connect
 endef
 
 define Package/rp-pppoe-relay/install  
 endef
 
 define Package/rp-pppoe-relay/install