[packages] usbutils: Do not automatically update USB IDs on real system
authorVasilis Tsiligiannis <acinonyx@openwrt.gr>
Wed, 13 Apr 2011 17:40:16 +0000 (17:40 +0000)
committerVasilis Tsiligiannis <acinonyx@openwrt.gr>
Wed, 13 Apr 2011 17:40:16 +0000 (17:40 +0000)
SVN-Revision: 26650

utils/usbutils/Makefile

index 033e5dec715fbc0b3e0a3b12a303704361c97eb5..fef5bfe3ebec1ea76866b7a8e0ed6843fd725301 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=usbutils
 PKG_VERSION:=002
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@KERNEL/linux/utils/usb/usbutils
@@ -29,6 +29,7 @@ endef
 
 define Package/usbutils/postinst
 #!/bin/sh
+[ -z "$${IPKG_INSTROOT}" ] || \
 (cd $${IPKG_INSTROOT}/usr/share; $${PKG_ROOT}/usr/sbin/update-usbids.sh ; rm usb.ids.gz.old)
 exit 0
 endef