[package] Package libdaq as a new Snort dependency
authorFlorian Fainelli <florian@openwrt.org>
Mon, 13 Aug 2012 14:08:38 +0000 (14:08 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Mon, 13 Aug 2012 14:08:38 +0000 (14:08 +0000)
libdaq, a data acquisition library needed by a Snort 2.9.x.

Signed-off-by: Jiri Slachta <jiri@slachta.eu>
SVN-Revision: 33168

libs/libdaq/Makefile [new file with mode: 0644]
libs/libdaq/patches/001-cross-compile-test.patch [new file with mode: 0644]

diff --git a/libs/libdaq/Makefile b/libs/libdaq/Makefile
new file mode 100644 (file)
index 0000000..57c8cd3
--- /dev/null
@@ -0,0 +1,69 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libdaq
+PKG_VERSION:=1.1.1
+PKG_RELEASE:=1
+
+PKG_SOURCE_URL:=http://www.snort.org/dl/snort-current/
+PKG_SOURCE:=daq-$(PKG_VERSION).tar.gz
+PKG_MD5SUM:=bc204ea09165b4ecbb1bb49c7c1a2ad4
+PKG_BUILD_DIR:=$(BUILD_DIR)/daq-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/nls.mk
+
+define Package/libdaq
+  SECTION:=libs
+  CATEGORY:=Libraries
+  TITLE:=DAQ library
+  URL:=$(PKG_SOURCE_URL)
+  DEPENDS:=+libdnet +libipq +libpcap
+endef
+
+define Package/libdaq/description
+ Data Acquisition library for packet I/O.
+endef
+
+CONFIGURE_ARGS+= \
+        --disable-static \
+        --with-dnet-includes="$(STAGING_DIR)/usr/include" \
+        --with-dnet-libraries="$(STAGING_DIR)/usr/lib" \
+        --with-libpcap-includes="$(STAGING_DIR)/usr/include" \
+        --with-libpcap-libraries="$(STAGING_DIR)/usr/lib" \
+
+define Build/Compile
+       $(MAKE) $(MAKE_FLAGS) -C $(PKG_BUILD_DIR)
+endef
+
+define Build/Install
+       $(MAKE) $(MAKE_FLAGS) -C $(PKG_BUILD_DIR) install DESTDIR=$(PKG_INSTALL_DIR)
+endef
+
+define Build/InstallDev
+       $(INSTALL_DIR) $(STAGING_DIR)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/*.h $(STAGING_DIR)/usr/include/
+       $(INSTALL_DIR) $(STAGING_DIR)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib* $(STAGING_DIR)/usr/lib/
+       $(INSTALL_DIR) $(STAGING_DIR)/usr/lib/daq
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/daq/* $(STAGING_DIR)/usr/lib/daq/
+       $(INSTALL_DIR) $(STAGING_DIR)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/daq-modules-config $(STAGING_DIR)/usr/bin/
+endef
+
+define Package/libdaq/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/*.so* $(1)/usr/lib/
+       $(INSTALL_DIR) $(1)/usr/lib/daq
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/daq/*.so* $(1)/usr/lib/daq/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/daq-modules-config $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,libdaq))
diff --git a/libs/libdaq/patches/001-cross-compile-test.patch b/libs/libdaq/patches/001-cross-compile-test.patch
new file mode 100644 (file)
index 0000000..6eadb9e
--- /dev/null
@@ -0,0 +1,18 @@
+--- daq-1.1.1/configure        2012-07-10 21:32:51.000000000 +0200
++++ daq-new/configure  2012-08-03 15:47:07.654945651 +0200
+@@ -12717,10 +12717,11 @@
+     { $as_echo "$as_me:${as_lineno-$LINENO}: checking for libpcap version >= \"1.0.0\"" >&5
+ $as_echo_n "checking for libpcap version >= \"1.0.0\"... " >&6; }
+     if test "$cross_compiling" = yes; then :
+-  { { $as_echo "$as_me:${as_lineno-$LINENO}: error: in \`$ac_pwd':" >&5
+-$as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
+-as_fn_error $? "cannot run test program while cross compiling
+-See \`config.log' for more details" "$LINENO" 5; }
++#  { { $as_echo "$as_me:${as_lineno-$LINENO}: error: in \`$ac_pwd':" >&5
++#$as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
++#as_fn_error $? "cannot run test program while cross compiling
++#See \`config.log' for more details" "$LINENO" 5; }
++        echo "    No cross compiling test."
+ else
+   cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h.  */