[packages] change ownership of the audiodevices to the pulse group to make it useable
authorPeter Wagner <​tripolar@gmx.at>
Wed, 18 Sep 2013 18:20:29 +0000 (18:20 +0000)
committerPeter Wagner <​tripolar@gmx.at>
Wed, 18 Sep 2013 18:20:29 +0000 (18:20 +0000)
by pulseaudio

Fixes #14175

Signed-off-by: Peter Wagner <tripolar@gmx.at>
SVN-Revision: 38045

sound/pulseaudio/Makefile
sound/pulseaudio/files/pulseaudio.init

index 0fc979be899c50705643cd9ff1d74ff4e602b41d..467b2b7e128f0c203950794bcf79bebce9247bbe 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pulseaudio
 PKG_VERSION:=4.0
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=http://freedesktop.org/software/pulseaudio/releases/
index 4ac63b3c3814391e284eff6db8c336b7ee635853..6ad6af3c04f6472c45ddfd052f8d22743cb2cac6 100644 (file)
@@ -20,6 +20,9 @@ start() {
                chmod 0750 /var/lib/pulse
                chown pulse:pulse /var/lib/pulse
        }
+       chown root:pulse /dev/snd/* /dev/mixer /dev/dsp
+       chmod 664 /dev/snd/* /dev/mixer /dev/dsp
+
        service_start /usr/bin/pulseaudio --daemonize --system --disallow-exit --disallow-module-loading --disable-shm --exit-idle-time=-1
 }