[package] add spidev_test utility from the kernel documentation
authorFlorian Fainelli <florian@openwrt.org>
Fri, 6 Mar 2009 01:11:44 +0000 (01:11 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Fri, 6 Mar 2009 01:11:44 +0000 (01:11 +0000)
SVN-Revision: 14753

package/spidev_test/Makefile [new file with mode: 0644]

diff --git a/package/spidev_test/Makefile b/package/spidev_test/Makefile
new file mode 100644 (file)
index 0000000..9663b61
--- /dev/null
@@ -0,0 +1,43 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id: $
+
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
+
+PKG_NAME:=spidev-test
+PKG_RELEASE:=$(LINUX_VERSION)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/spidev-test
+  SECTION:=utils
+  CATEGORY:=Utilites
+  DEPENDS:=@LINUX_2_6
+  TITLE:=SPI testing utility
+  VERSION:=$(LINUX_VERSION)-$(PKG_RELEASE)
+  URL:=http://www.kernel.org
+endef
+
+define Package/spidev-test/description
+  SPI testing utility.
+endef
+
+define Build/Prepare
+endef
+
+define Build/Compile
+       $(TARGET_CC) $(TARGET_CFLAGS) -o $(PKG_BUILD_DIR)/spidev_test \
+               $(LINUX_DIR)/Documentation/spi/spidev_test.c
+endef
+
+define Package/spidev-test/install
+       $(INSTALL_DIR) $(1)/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/spidev_test $(1)/sbin/
+endef
+
+$(eval $(call BuildPackage,spidev-test))