Fix postgresql installation when already compiled
authorFlorian Fainelli <florian@openwrt.org>
Wed, 20 Feb 2008 14:43:14 +0000 (14:43 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Wed, 20 Feb 2008 14:43:14 +0000 (14:43 +0000)
SVN-Revision: 10503

libs/postgresql/Makefile

index 28a5302cc969eb81c7526fcf5e4c851c8a7cb4ce..5d60831e7ba38600f677e025d362859451607a3a 100644 (file)
@@ -205,8 +205,7 @@ define Package/pgsql-server/install
                $(PKG_INSTALL_DIR)/usr/bin/reindexdb \
                $(PKG_INSTALL_DIR)/usr/bin/vacuumdb \
                $(1)/usr/bin
-
-        ln -s postgres $(1)/usr/bin/postmaster
+       ln -sf postgres $(1)/usr/bin/postmaster
 
        $(INSTALL_BIN) ./files/postgresql.init $(1)/etc/init.d/postgresql