update openswan to latest upstream version and add fixes for 2.6.21 api changes
authorFelix Fietkau <nbd@openwrt.org>
Mon, 28 May 2007 20:43:18 +0000 (20:43 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 28 May 2007 20:43:18 +0000 (20:43 +0000)
SVN-Revision: 7379

package/openswan/Makefile
package/openswan/patches/110-scripts.patch
package/openswan/patches/130-linux_2.6.19_api_changes.patch [deleted file]
package/openswan/patches/130-sysctl_api_change.patch [new file with mode: 0644]
package/openswan/patches/200-linux_pfkey_2.4.patch [deleted file]

index a3012893c303a3bd9a960b9d73f1c3625273a091..1fd2e20af6016a5d55485b715cc9839acdc2327c 100644 (file)
@@ -10,12 +10,12 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=openswan
-PKG_VERSION:=2.4.7
+PKG_VERSION:=2.4.8
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.openswan.org/download
-PKG_MD5SUM:=70f22e8adc39e07a165f75eccb7cd079
+PKG_MD5SUM:=918cc56ccf8e5d14cd2047e47450b34a
 
 include $(INCLUDE_DIR)/package.mk
 
index ed37920a395a762df49d4cbd7a53b6e1535d2cda..a350cd123810ce9f925abaf29c6a0baf3f38280a 100644 (file)
@@ -227,15 +227,4 @@ diff -ruN openswan-2.4.7-old/programs/_startklips/_startklips.in openswan-2.4.7-
                if test ! -f $ipsecversion
                then
                        echo "kernel appears to lack IPsec support (neither CONFIG_KLIPS or CONFIG_NET_KEY are set)"
-diff -urN openswan-2.4.7/programs/_startklips/_startklips.in openswan-2.4.7.new/programs/_startklips/_startklips.in
---- openswan-2.4.7/programs/_startklips/_startklips.in 2006-11-13 21:27:18.000000000 +0100
-+++ openswan-2.4.7.new/programs/_startklips/_startklips.in     2007-04-16 11:57:45.000000000 +0200
-@@ -147,7 +147,7 @@
-       then
-               # attach the interface and bring it up
-               ipsec tncfg --attach --virtual $virt --physical $phys
--              ifconfig $virt inet $addr $type $otheraddr netmask $mask $mtu
-+              ifconfig $virt $addr $type $otheraddr netmask $mask $mtu
-       fi
-       # if %defaultroute, note the facts
+
diff --git a/package/openswan/patches/130-linux_2.6.19_api_changes.patch b/package/openswan/patches/130-linux_2.6.19_api_changes.patch
deleted file mode 100644 (file)
index a9e6801..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -bruN openswan-2.4.7-old/linux/net/ipsec/pfkey_v2.c openswan-2.4.7-new/linux/net/ipsec/pfkey_v2.c
---- openswan-2.4.7-old/linux/net/ipsec/pfkey_v2.c      2006-10-10 22:43:28.000000000 +0200
-+++ openswan-2.4.7-new/linux/net/ipsec/pfkey_v2.c      2006-12-15 17:29:02.000000000 +0100
-@@ -1503,7 +1503,7 @@
-       
-         printk(KERN_INFO "klips_info:pfkey_cleanup: "
-              "shutting down PF_KEY domain sockets.\n");
--        error |= sock_unregister(PF_KEY);
-+        sock_unregister(PF_KEY);
-       error |= supported_remove_all(SADB_SATYPE_AH);
-       error |= supported_remove_all(SADB_SATYPE_ESP);
diff --git a/package/openswan/patches/130-sysctl_api_change.patch b/package/openswan/patches/130-sysctl_api_change.patch
new file mode 100644 (file)
index 0000000..e01b94e
--- /dev/null
@@ -0,0 +1,16 @@
+diff -ur openswan.old/linux/net/ipsec/sysctl_net_ipsec.c openswan.dev/linux/net/ipsec/sysctl_net_ipsec.c
+--- openswan.old/linux/net/ipsec/sysctl_net_ipsec.c    2004-07-10 21:11:18.000000000 +0200
++++ openswan.dev/linux/net/ipsec/sysctl_net_ipsec.c    2007-05-28 22:40:57.001031592 +0200
+@@ -130,7 +130,11 @@
+ int ipsec_sysctl_register(void)
+ {
+-        ipsec_table_header = register_sysctl_table(ipsec_root_table, 0);
++#if LINUX_VERSION_CODE > KERNEL_VERSION(2,6,20)
++              ipsec_table_header = register_sysctl_table(ipsec_root_table);
++#else
++              ipsec_table_header = register_sysctl_table(ipsec_root_table, 0);
++#endif
+         if (!ipsec_table_header) {
+                 return -ENOMEM;
+       }
diff --git a/package/openswan/patches/200-linux_pfkey_2.4.patch b/package/openswan/patches/200-linux_pfkey_2.4.patch
deleted file mode 100644 (file)
index 15f9fa7..0000000
+++ /dev/null
@@ -1,33 +0,0 @@
-diff -urN openswan-2.4.7.old/linux/net/ipsec/pfkey_v2.c openswan-2.4.7/linux/net/ipsec/pfkey_v2.c
---- openswan-2.4.7.old/linux/net/ipsec/pfkey_v2.c      2007-01-03 11:11:04.645909731 +0000
-+++ openswan-2.4.7/linux/net/ipsec/pfkey_v2.c  2007-01-03 11:14:54.482143945 +0000
-@@ -119,7 +119,9 @@
- #ifdef NETDEV_23
-       .family = PF_KEY,
-       .create = pfkey_create,
-+#ifdef NET_26
-       .owner  = THIS_MODULE,
-+#endif
- #else
-       PF_KEY,
-       pfkey_create
-@@ -129,7 +131,9 @@
- struct proto_ops SOCKOPS_WRAPPED(pfkey_ops) = {
- #ifdef NETDEV_23
-       family:         PF_KEY,
-+#ifdef NET_26
-       owner:          THIS_MODULE,
-+#endif
-       release:        pfkey_release,
-       bind:           sock_no_bind,
-       connect:        sock_no_connect,
-@@ -1559,6 +1563,9 @@
- /*
-  * $Log: pfkey_v2.c,v $
-+ * Revision 1.97.2.11  2006/11/15 16:05:57  paul
-+ * fix for compiling on 2.4. kernels by Matthias Haas.
-+ *
-  * Revision 1.97.2.10  2006/10/10 20:43:28  paul
-  * Add family/create/owner for pfkey_family_ops. This fixes bug #671
-  *