[packages] appweb: update to 3.2.2-1 (closes: #6979), add dependency on libpthread...
authorNicolas Thill <nico@openwrt.org>
Tue, 3 Aug 2010 07:36:15 +0000 (07:36 +0000)
committerNicolas Thill <nico@openwrt.org>
Tue, 3 Aug 2010 07:36:15 +0000 (07:36 +0000)
SVN-Revision: 22469

net/appweb/Makefile
net/appweb/patches/100-compile_fix.patch [deleted file]

index 0f3fb36f0d167d5b64dddf627a8103b2d89c6b92..b30fa8dec8739e8dd36d029222f813ae1e9d15ef 100644 (file)
@@ -1,12 +1,12 @@
 #
 #
-#      Makefile for the Appweb Web Server
+# Copyright (C) 2009-2010 OpenWrt.org
+# Copyright (C) 2009 Embedthis Software
 #
 #
-#      Copyright (C) 2009 Embedthis Software
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
 #
 #
-#      This software is licensed under the GPLv2. Commercial and other licenses
-#   are available from http://www.embedthis.com.
+# Commercial and other licenses are available from http://www.embedthis.com/.
 #
 #
-#      $Id$
 
 include $(TOPDIR)/rules.mk
 
 
 include $(TOPDIR)/rules.mk
 
@@ -14,41 +14,42 @@ PKG_NAME:=appweb
 PKG_RELEASE:=1
 
 #
 PKG_RELEASE:=1
 
 #
-#      Build 3.0B.3
+#      Build stable
 #
 #
-PKG_SOURCE_URL:=http://www.appwebserver.org/software/
-PKG_VERSION:=3.0B.2-3
-PKG_MD5SUM:=b54a99d388a5588a9af33aa1c6354e06
+PKG_VERSION:=3.2.2-1
 PKG_SOURCE:=$(PKG_NAME)-src-$(PKG_VERSION).tar.gz
 PKG_SOURCE:=$(PKG_NAME)-src-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://www.appwebserver.org/software/
+PKG_MD5SUM:=060d43c8194fa6a119cada966fc807a7
+
 #
 #      Build the latest snapshot from the default trunk
 #
 #
 #      Build the latest snapshot from the default trunk
 #
-#      PKG_SOURCE:=tip.tar.gz
-#      PKG_SOURCE_URL:= http://hg.embedthis.com/appweb/archive/
-#      PKG_VERSION:=default
-#      PKG_MD5SUM:=
+#PKG_VERSION:=default
+#PKG_SOURCE:=tip.tar.gz
+#PKG_SOURCE_URL:= http://hg.embedthis.com/appweb/archive/
+#PKG_MD5SUM:=
 
 include $(INCLUDE_DIR)/package.mk
 
 
 include $(INCLUDE_DIR)/package.mk
 
-CONFIGURE_ARGS += -q --defaults=release --shared --tune=size --without-php \
-       --without-ssl --disable-angel --disable-samples --disable-access-log \
-       --disable-complete-native --disable-complete-cross --webdir=/www \
-       --logdir=/var/log --port=8000 --sslPort=8443 --config=flat
-
 define Package/appweb
   SECTION:=net
   CATEGORY:=Network
   TITLE:=Appweb Web Server
 define Package/appweb
   SECTION:=net
   CATEGORY:=Network
   TITLE:=Appweb Web Server
-  VERSION:=$(PKG_VERSION)
   URL:=http://www.appwebserver.org/
   URL:=http://www.appwebserver.org/
-  DEPENDS:=@!avr32
+  DEPENDS:=@!avr32 +libpthread
 endef
 
 define Package/appweb/description
 endef
 
 define Package/appweb/description
      Appweb is a powerful, compact embedded web server designed for dynamic web
      applications.
+ Appweb is a powerful, compact embedded web server designed for dynamic web
+ applications.
 endef
 
 endef
 
+CONFIGURE_ARGS += \
+       -q --defaults=release --shared --tune=size --without-php \
+       --without-ssl --disable-angel --disable-samples --disable-access-log \
+       --disable-complete-native --disable-complete-cross --webdir=/www \
+       --logdir=/var/log --port=8000 --sslPort=8443 --config=flat
+
 define Build/Prepare
        tar xzf "$(DL_DIR)/$(PKG_SOURCE)" --strip-components 1 -C "$(PKG_BUILD_DIR)"
 endef
 define Build/Prepare
        tar xzf "$(DL_DIR)/$(PKG_SOURCE)" --strip-components 1 -C "$(PKG_BUILD_DIR)"
 endef
@@ -68,4 +69,3 @@ define Package/appweb/install
 endef
 
 $(eval $(call BuildPackage,appweb))
 endef
 
 $(eval $(call BuildPackage,appweb))
-
diff --git a/net/appweb/patches/100-compile_fix.patch b/net/appweb/patches/100-compile_fix.patch
deleted file mode 100644 (file)
index 8e53263..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
---- a/src/ejs/ejsLib.c
-+++ b/src/ejs/ejsLib.c
-@@ -21544,11 +21544,13 @@ EjsVar *ejsThrowInternalError(Ejs *ejs, 
- EjsVar *ejsThrowMemoryError(Ejs *ejs)
- {
-+    va_list     fmtArgs;
-+
-     /*
-      *  Don't do double exceptions for memory errors
-      */
-     if (ejs->exception == 0) {
--        return ejsCreateException(ejs, ES_MemoryError, 0, 0);
-+        return ejsCreateException(ejs, ES_MemoryError, NULL, fmtArgs);
-     }
-     return ejs->exception;
- }