support for the asus wl-500g deluxe and the buffalo v2 units. dnsmasq update, control...
authorImre Kaloz <kaloz@openwrt.org>
Sat, 19 Mar 2005 17:52:30 +0000 (17:52 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Sat, 19 Mar 2005 17:52:30 +0000 (17:52 +0000)
SVN-Revision: 390

openwrt/package/dnsmasq/Makefile
openwrt/package/dnsmasq/dnsmasq.control
openwrt/package/dropbear/dropbear.control
openwrt/package/iptables/control/ip6tables.control
openwrt/package/iptables/control/iptables-extra.control
openwrt/package/iptables/control/iptables.control
openwrt/package/linux/kernel-source/arch/mips/brcm-boards/bcm947xx/sbpci.c
openwrt/package/linux/kernel-source/drivers/net/diag/diag_led.c
openwrt/target/default/target_skeleton/etc/init.d/S10boot
openwrt/target/default/target_skeleton/etc/nvram.overrides

index 899bad799fb5d2f1c3ad68d64bb14f03fef0ed61..761b79843b87f42585688d86cec2ac38e6a7649c 100644 (file)
@@ -6,7 +6,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dnsmasq
-PKG_VERSION:=2.15
+PKG_VERSION:=2.20
 PKG_RELEASE:=1
 PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
index ef6bd0db30a1eb5e4f6ea7390e46d161aa35763f..3aba02b51db2bb97df0caeef4e59f5f62a93e202 100644 (file)
@@ -1,7 +1,7 @@
 Package: dnsmasq
 Priority: essential
 Section: net
-Version: 2.15-1
+Version: 2.20-1
 Architecture: mipsel
 Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
 Source: buildroot internal
index e30f02ac5c4bccd0be63ef5cb4838891db58f1ed..1a2f5ed9709f13a4adc42d71f6f8ee7e403d0777 100644 (file)
@@ -2,7 +2,7 @@ Package: dropbear
 Priority: optional
 Depends: zlib
 Section: net
-Version: 0.44-1
+Version: 0.45-1
 Architecture: mipsel
 Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
 Source: buildroot internal
index 4f7da5645a5d2d1a54f027ef28586162ffc6cb51..6739656c7fd47b6fe7d299f73b85eed16d2da54b 100644 (file)
@@ -2,7 +2,7 @@ Package: ip6tables
 Priority: optional
 Depends: kmod-ipv6
 Section: net
-Version: 1.2.11-1
+Version: 1.3.0-1
 Architecture: mipsel
 Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
 Source: buildroot internal
index 2ce60446420bb93eef21d7186c05ff9101cfa55e..eb3dd7bed1ffe0c3d4fa51783e2e442952cf26cd 100644 (file)
@@ -1,7 +1,7 @@
 Package: iptables-extra
 Priority: optional
 Section: net
-Version: 1.2.11-1
+Version: 1.3.0-1
 Architecture: mipsel
 Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
 Source: buildroot internal
index 09a99b5b04bfa5e49b5263a5baa39f06f2d3bfbd..6b7ab38a65229b7bbbd49ea141dc2a736101d9b6 100644 (file)
@@ -1,7 +1,7 @@
 Package: iptables
 Priority: optional
 Section: net
-Version: 1.2.11-1
+Version: 1.3.0-1
 Architecture: mipsel
 Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
 Source: buildroot internal
index b3469134ebee7df6927cdf8cf79442e23e69ef14..ead31e9aa5ae86cb77701eb5cc6b4d599d68503c 100644 (file)
@@ -275,7 +275,7 @@ sbpci_init(void *sbh)
        sb_core_reset(sbh, 0);
 
        /* In some board, */ 
-       if(nvram_match("boardtype", "bcm94710dev"))
+       if(nvram_match("boardtype", "bcm94710dev") || nvram_match("boardtype", "bcm94710ap")|| nvram_match("boardtype", "bcm94710r4")|| nvram_match("boardtype", "bcm94710r4")|| nvram_match("boardtype", "bcm95365r"))
                CT4712_WR = 0;
        else
                CT4712_WR = 1;
index 41cb17bf4d5b880ca21401660e561536f1146d38..6f1ba97324ec214a5fc376fccd121df620e989d9 100644 (file)
@@ -5,6 +5,7 @@
 // initial release 2004/03/28
 //
 // 2004/08/26 asus & buffalo support added
+// 2005/03/14 asus wl-500g deluxe and buffalo v2 support added
 
 #include <linux/module.h>
 #include <linux/init.h>
@@ -187,11 +188,26 @@ static int __init diag_init()
                reset_polarity=0;
                buf=nvram_get("boardnum")?:"";
                if (!strcmp(buf,"44")) {
+                       //motorola
                        set_diag=ignore;
                        set_dmz=ignore;
                        reset_gpio=(1<<5);
                        reset_polarity=0;
                }
+               if (!strcmp(buf,"00")) {
+                       //buffalo
+                       set_diag=ignore;
+                       set_dmz=ignore;
+                       reset_gpio=(1<<7);
+                       reset_polarity=1;
+               }
+               if (!strcmp(buf,"45")) {
+                       //wl-500g deluxe
+                       set_diag=ignore;
+                       set_dmz=ignore;
+                       reset_gpio=(1<<6);
+                       reset_polarity=1;
+               }
        }
        printk(KERN_INFO "using v%d hardware\n",board_type);
 
index 928fc585f05ea3c229db9c0c45d7955e306d7c29..1a36583cc289b783c7b1274291e4242339e8857d 100755 (executable)
@@ -15,6 +15,16 @@ touch /var/log/lastlog
   awk '{OFS=FS=":";for(x=7,y=2;--x;){$x=sprintf("%02x",(y+="0x"$x)%256);y/=256}print}')
 }
 
+# set up the vlan*ports variables for the asus wl-500g deluxe, if they aren't exist
+[ "$(nvram get boardtype)" = "bcm95365r" ] && \
+[ "$(nvram get boardnum)" = "45" ] && {
+  [ -z "$(nvram get vlan0ports)" ] && \
+  [ -z "$(nvram get vlan1ports)" ] && {
+    nvram set vlan0ports="1 2 3 4 5*"
+    nvram set vlan1ports="0 5"
+  }
+}
+
 sed 's/^[^#]/insmod &/' /etc/modules 2>&-|ash
 
 ifconfig lo 127.0.0.1 up
index 206c90b0ddbab07a6d34d4ef4374cce9e37fc991..82c15900ea99a0a8ce1b3805bcaeda240a94a8e4 100644 (file)
@@ -45,11 +45,29 @@ NVRAM_lan_proto="static"
   FAILSAFE_ifnames="eth0 eth1"
 }
 
+# hacks for buffalo wla2-g54l
+[ "$(nvram get boardnum)" = "00" ] && \
+[ "$(nvram get product_name)" = "Product_name" ] && {
+  debug "### wla2-g54l hacks ###"
+  NVRAM_lan_ifnames="vlan0"
+  NVRAM_wan_ifname="none"
+}
+
 # hack for asus wl-500g hardware
 [ $asus ] && {
     FAILSAFE_lan_ifnames="eth0 eth2"
 }
 
+# hacks for asus wl-500g deluxe
+[ "$(nvram get boardtype)" = "bcm95365r" ] && \
+[ "$(nvram get boardnum)" = "45" ] && {
+  debug "### wl-500g deluxe hacks ###"
+  NVRAM_vlan0hwname="et0"
+  NVRAM_vlan1hwname="et0"
+  NVRAM_lan_ifnames="vlan0 eth1"
+  NVRAM_wan_ifname="vlan1"
+}
+
 # defaults if lan_ifname is missing
 [ -z "$(nvram get lan_ifname)" ] && {
   NVRAM_lan_ifname="br0"