[packages] dstat: move to the correct directory
authorJo-Philipp Wich <jow@openwrt.org>
Tue, 24 Jan 2012 14:19:15 +0000 (14:19 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Tue, 24 Jan 2012 14:19:15 +0000 (14:19 +0000)
SVN-Revision: 29888

dstat/Makefile [deleted file]
utils/dstat/Makefile [new file with mode: 0644]

diff --git a/dstat/Makefile b/dstat/Makefile
deleted file mode 100644 (file)
index c05d405..0000000
+++ /dev/null
@@ -1,47 +0,0 @@
-#
-# Copyright (C) 2012 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=dstat
-PKG_VERSION:=0.7.2
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://dag.wieers.com/home-made/dstat/
-PKG_MD5SUM:=bfea4dc8037a0b18fc40a4dfc104dcc8
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/dstat
-  SECTION:=utils
-  CATEGORY:=Utilities
-  TITLE:=Versatile resource statistics tool
-  URL:=http://dag.wieers.com/home-made/dstat/
-  DEPENDS:=+python
-endef
-
-define Package/dstat/description
-  Dstat is a versatile replacement for vmstat, iostat, netstat
-  and ifstat. Dstat overcomes some of their limitations and
-  adds some extra features, more counters and flexibility.
-  Dstat is handy for monitoring systems during performance
-  tuning tests, benchmarks or troubleshooting.
-endef
-
-define Build/Compile
-endef
-
-define Package/dstat/install
-       $(INSTALL_DIR) $(1)/usr/share/dstat
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/dstat $(1)/usr/share/dstat/dstat.py
-       $(INSTALL_DATA) $(PKG_BUILD_DIR)/plugins/dstat_*.py $(1)/usr/share/dstat/
-       $(INSTALL_DIR) $(1)/usr/bin
-       $(LN) -sf ../share/dstat/dstat.py $(1)/usr/bin/dstat
-endef
-
-$(eval $(call BuildPackage,dstat))
diff --git a/utils/dstat/Makefile b/utils/dstat/Makefile
new file mode 100644 (file)
index 0000000..c05d405
--- /dev/null
@@ -0,0 +1,47 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=dstat
+PKG_VERSION:=0.7.2
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://dag.wieers.com/home-made/dstat/
+PKG_MD5SUM:=bfea4dc8037a0b18fc40a4dfc104dcc8
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/dstat
+  SECTION:=utils
+  CATEGORY:=Utilities
+  TITLE:=Versatile resource statistics tool
+  URL:=http://dag.wieers.com/home-made/dstat/
+  DEPENDS:=+python
+endef
+
+define Package/dstat/description
+  Dstat is a versatile replacement for vmstat, iostat, netstat
+  and ifstat. Dstat overcomes some of their limitations and
+  adds some extra features, more counters and flexibility.
+  Dstat is handy for monitoring systems during performance
+  tuning tests, benchmarks or troubleshooting.
+endef
+
+define Build/Compile
+endef
+
+define Package/dstat/install
+       $(INSTALL_DIR) $(1)/usr/share/dstat
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/dstat $(1)/usr/share/dstat/dstat.py
+       $(INSTALL_DATA) $(PKG_BUILD_DIR)/plugins/dstat_*.py $(1)/usr/share/dstat/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(LN) -sf ../share/dstat/dstat.py $(1)/usr/bin/dstat
+endef
+
+$(eval $(call BuildPackage,dstat))