[package] fix luasocket compilation failures (#6065)
authorFlorian Fainelli <florian@openwrt.org>
Thu, 29 Oct 2009 10:59:47 +0000 (10:59 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Thu, 29 Oct 2009 10:59:47 +0000 (10:59 +0000)
SVN-Revision: 18200

lang/luasocket/Makefile

index d2673c2458f3590b3bd6b6a898341b25e097afcf..3d503d7e77c26efa5dcbf1b22b6dae98bba1e32b 100644 (file)
@@ -38,7 +38,7 @@ endef
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR)/ all \
        LIBDIR="$(TARGET_LDFLAGS)" \
-       CC="$(TARGET_CC) $(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
+       CC="$(TARGET_CC) $(TARGET_CFLAGS) $(TARGET_CPPFLAGS) -std=gnu99" \
        LD="$(TARGET_CROSS)ld -shared" 
 endef