mount nfsd on /proc/fs/nfsd
authorPeter Wagner <​tripolar@gmx.at>
Thu, 25 Feb 2010 02:28:02 +0000 (02:28 +0000)
committerPeter Wagner <​tripolar@gmx.at>
Thu, 25 Feb 2010 02:28:02 +0000 (02:28 +0000)
install sm-notify

based on a patch by  Benjamin Cama <benoar@free.fr>

SVN-Revision: 19855

net/nfs-kernel-server/Makefile
net/nfs-kernel-server/files/nfsd.init

index 220fd5ac09d5409ff5d072a214122826859f831d..228c245bb7cec77c62a108b06fecf6d9055df3f1 100644 (file)
@@ -84,6 +84,7 @@ define Package/nfs-kernel-server/install
        $(INSTALL_DIR) $(1)/etc/init.d $(1)/usr/sbin
        $(INSTALL_DATA) ./files/nfsd.exports $(1)/etc/exports
        $(INSTALL_BIN) ./files/nfsd.init $(1)/etc/init.d/nfsd
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/utils/statd/sm-notify $(1)/usr/sbin/
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/utils/statd/statd $(1)/usr/sbin/rpc.statd
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/utils/nfsd/nfsd $(1)/usr/sbin/rpc.nfsd
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/utils/mountd/mountd $(1)/usr/sbin/rpc.mountd
index bf658d0a1a9fe29bb981037de5892aa188bfb06b..104b0e954059ac9d300dd61bfa7f3bbb43ddd843 100644 (file)
@@ -8,6 +8,8 @@ NFS_D=/var/lib/nfs
 LOCK_D=/var/lib/nfs/sm
 
 start() {
+       grep -q /proc/fs/nsfd /proc/mounts || \
+               mount -t nfsd nfsd /proc/fs/nfsd
        mkdir -p $NFS_D
        mkdir -p $LOCK_D
        touch $NFS_D/rmtab
@@ -24,6 +26,8 @@ stop() {
        rpc.nfsd 0 2> /dev/null
        /usr/sbin/exportfs -au
        killall rpc.statd 2> /dev/null
+       grep -q /proc/fs/nfsd /proc/mounts &&
+               umount /proc/fs/nfsd
 }
 
 reload() {