[packages] re: infer SYSROOT from the cross cpp's idea of pthread.h location
authorJo-Philipp Wich <jow@openwrt.org>
Thu, 19 Jan 2012 13:14:07 +0000 (13:14 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Thu, 19 Jan 2012 13:14:07 +0000 (13:14 +0000)
Until now, SYSROOT was always assumed to be $(TOOLCHAIN_DIR), but neither
backfire nor external toolchains put their core headers into $(TOOLCHAIN_DIR)/include,
therfore feature detection failed badly.

SVN-Revision: 29799

libs/re/Makefile
libs/re/patches/200-stdint.h.patch [deleted file]

index 4fa53106e6376e3c97898b39661f7763ff8b9aa4..e6f9ed4ce51add3d1c770a4e4ecb8e201d0c9c7b 100644 (file)
@@ -35,7 +35,7 @@ define Build/Compile
                EXTRA_CFLAGS="$(TARGET_CFLAGS) -DOPENWRT" \
                EXTRA_LFLAGS="-lm" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
-               SYSROOT="$(TOOLCHAIN_DIR)" \
+               SYSROOT="$$$$(echo '#include <pthread.h>' | $(TARGET_CROSS)cpp -x c | sed -ne 's,^# [0-9]* \"\(.*\)/include/pthread\.h\".*,\1,p' | head -n1)" \
                SYSROOT_ALT="$(STAGING_DIR)/usr" \
                RELEASE=1 \
                CROSS_COMPILE="$(TARGET_CROSS)" \
diff --git a/libs/re/patches/200-stdint.h.patch b/libs/re/patches/200-stdint.h.patch
deleted file mode 100644 (file)
index 58f9a93..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/include/re_types.h
-+++ b/include/re_types.h
-@@ -5,6 +5,7 @@
-  */
- #include <sys/types.h>
-+#include <stdint.h>
- #ifdef _MSC_VER
- #include <stdlib.h>