fix curl compile
authorFelix Fietkau <nbd@openwrt.org>
Tue, 15 Jan 2008 13:16:47 +0000 (13:16 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Tue, 15 Jan 2008 13:16:47 +0000 (13:16 +0000)
SVN-Revision: 10204

libs/curl/Makefile

index 8f3abf2da5fc94b5cc4dc7bc8daee568afd3c1ca..0f80736581b3608eee3482485043ff805f8eb8f5 100644 (file)
@@ -78,14 +78,17 @@ CONFIGURE_ARGS += \
 
 CONFIGURE_VARS += \
        LDFLAGS="$$$$LDFLAGS -lcrypto -lssl -lz" \
-
+       CC="$(filter-out ccache,$(TARGET_CC))"
 
 define Build/Configure
        $(call Build/Configure/Default,,bash)
 endef
 
 define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" install
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               CC="$(TARGET_CC)" \
+               install
 endef
 
 define Build/InstallDev