Add gdbserver package, keep things sorted
authorNicolas Thill <nico@openwrt.org>
Fri, 17 Jun 2005 06:21:17 +0000 (06:21 +0000)
committerNicolas Thill <nico@openwrt.org>
Fri, 17 Jun 2005 06:21:17 +0000 (06:21 +0000)
SVN-Revision: 1266

openwrt/package/Config.in
openwrt/package/Makefile
openwrt/package/gdbserver/Config.in [new file with mode: 0644]
openwrt/package/gdbserver/Makefile [new file with mode: 0644]
openwrt/package/gdbserver/ipkg/gdbserver.control [new file with mode: 0644]

index 0811317f6053e3d6a1d942962dbac861cabf639f..18b1d90110d19730cf5976dd0a5ee1ce3f73d596 100644 (file)
@@ -130,6 +130,7 @@ source "package/picocom/Config.in"
 source "package/setserial/Config.in"
 
 comment "Utilities ---"
+source "package/gdbserver/Config.in"
 source "package/usbutils/Config.in"  # lsusb
 source "package/strace/Config.in"
 
index 0cc914fa19952717eb93ca7673c8b975f73eaefe..89e90196023d866ea6aa39769b47f4df1d0a226c 100644 (file)
@@ -25,7 +25,7 @@ package-$(BR2_PACKAGE_FPROBE) += fprobe
 package-$(BR2_PACKAGE_FREERADIUS) += freeradius
 package-$(BR2_PACKAGE_FRICKIN) += frickin
 package-$(BR2_PACKAGE_FUSE) += fuse
-package-$(BR2_PACKAGE_GDB) += gdb
+package-$(BR2_PACKAGE_GDBSERVER) += gdbserver
 package-$(BR2_PACKAGE_GLIB) += glib
 package-$(BR2_PACKAGE_GMP) += gmp
 package-$(BR2_PACKAGE_GNUTLS) += gnutls
@@ -135,7 +135,6 @@ clean: $(patsubst %,%-clean,$(package-) $(package-y) $(package-m))
 compile: $(patsubst %,%-compile,$(package-y) $(package-m))
 install: $(patsubst %,%-install,$(package-y))
 
-wificonf-compile: openwrt-compile wireless-tools-compile
 arpwatch-compile: libpcap-compile
 cyrus-sasl-compile: openssl-compile
 dropbear-compile: zlib-compile
@@ -170,8 +169,9 @@ sipsak-compile: openssl-compile
 sqlite-compile: ncurses-compile readline-compile
 tcpdump-compile: libpcap-compile
 tinc-compile: zlib-compile openssl-compile lzo-compile
-vtun-compile: zlib-compile openssl-compile lzo-compile
 tor-compile: libevent-compile openssl-compile zlib-compile
+vtun-compile: zlib-compile openssl-compile lzo-compile
+wificonf-compile: openwrt-compile wireless-tools-compile
 wpa_supplicant-compile: openssl-compile
 
 asterisk-compile: openssl-compile
diff --git a/openwrt/package/gdbserver/Config.in b/openwrt/package/gdbserver/Config.in
new file mode 100644 (file)
index 0000000..15d8f20
--- /dev/null
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_GDBSERVER
+       tristate "gdbserver - Remote Server for the GNU Debugger"
+       default m if CONFIG_DEVEL
+       help
+        GDBSERVER is a program that allows you to run GDB on a different machine
+        than the one which is running the program being debugged.
+        
+
diff --git a/openwrt/package/gdbserver/Makefile b/openwrt/package/gdbserver/Makefile
new file mode 100644 (file)
index 0000000..4e011db
--- /dev/null
@@ -0,0 +1,62 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=gdbserver
+PKG_VERSION:=6.3
+PKG_RELEASE:=1
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+GDB_DIR:=$(TOOL_BUILD_DIR)/gdb-$(PKG_VERSION)
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,GDBSERVER,gdbserver,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+
+$(PKG_BUILD_DIR)/.prepared:
+       rm -rf $(PKG_BUILD_DIR)
+       mkdir -p $(PKG_BUILD_DIR)
+       touch $@
+
+$(PKG_BUILD_DIR)/.configured:
+       (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status}; \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               $(GDB_DIR)/gdb/gdbserver/configure \
+                 --target=$(GNU_TARGET_NAME) \
+                 --host=$(GNU_TARGET_NAME) \
+                 --build=$(GNU_HOST_NAME) \
+                 --program-prefix="" \
+                 --program-suffix="" \
+                 --prefix=/usr \
+                 --exec-prefix=/usr \
+                 --bindir=/usr/bin \
+                 --sbindir=/usr/sbin \
+                 --libexecdir=/usr/lib \
+                 --sysconfdir=/etc \
+                 --datadir=/usr/share \
+                 --localstatedir=/var \
+                 --mandir=/usr/man \
+                 --infodir=/usr/info \
+                 $(DISABLE_NLS) \
+                 $(DISABLE_LARGEFILE) \
+       );
+       touch $@
+
+$(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/.configured
+       rm -rf $(PKG_INSTALL_DIR)
+       mkdir -p $(PKG_INSTALL_DIR)
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               install
+       touch $@
+
+$(IPKG_GDBSERVER):
+       install -m0755 -d $(IDIR_GDBSERVER)/usr/bin
+       cp -fpR $(PKG_INSTALL_DIR)/usr/bin/gdbserver $(IDIR_GDBSERVER)/usr/bin/
+       $(RSTRIP) $(IDIR_GDBSERVER)
+       $(IPKG_BUILD) $(IDIR_GDBSERVER) $(PACKAGE_DIR)
+
diff --git a/openwrt/package/gdbserver/ipkg/gdbserver.control b/openwrt/package/gdbserver/ipkg/gdbserver.control
new file mode 100644 (file)
index 0000000..6ddb831
--- /dev/null
@@ -0,0 +1,8 @@
+Package: gdbserver
+Priority: optional
+Section: devel
+Version: [TBDL]
+Architecture: [TBDL]
+Maintainer: OpenWrt Developers Team <bugs@openwrt.org>
+Source: http://openwrt.org/cgi-bin/viewcvs.cgi/openwrt/package/gdbserver/
+Description: Remote Server for the GNU Debugger