[package] cleanup Makefiles (#7212)
authorJo-Philipp Wich <jow@openwrt.org>
Fri, 23 Apr 2010 11:27:29 +0000 (11:27 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Fri, 23 Apr 2010 11:27:29 +0000 (11:27 +0000)
SVN-Revision: 21107

package/comgt/Makefile
package/compcache/Makefile
package/gdb/Makefile
package/goldfish-qemu/Makefile
package/ifxmips-dsl-api/Makefile
package/ifxmips-dsl-control/Makefile
package/kernel/Makefile
package/ocf-crypto-headers/Makefile
package/ps3-utils/Makefile
package/uboot-envtools/Makefile
package/uboot-xburst/Makefile

index 999c614b3bb7c3d6099d60f26c3c2c0d285953c6..3c638db4e9b96ab3e193de8df71db758671097b2 100644 (file)
@@ -1,5 +1,5 @@
 #
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -24,7 +24,7 @@ define Package/comgt
   CATEGORY:=Utilities
   TITLE:=Option/Vodafone 3G/GPRS control tool
   DEPENDS:=+chat
   CATEGORY:=Utilities
   TITLE:=Option/Vodafone 3G/GPRS control tool
   DEPENDS:=+chat
-  URL:= http://www.pharscape.org/content/view/46/70/
+  URL:=http://www.pharscape.org/comgt.html
 endef
 
 define Package/comgt/description
 endef
 
 define Package/comgt/description
index 13a9056db41da59ff66e9958fce2f7e2bfd86b75..feb6cd3154527d9cd924693256f952ab2808ca31 100644 (file)
@@ -1,10 +1,9 @@
 #
 #
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2009-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: Makefile 6562 2009-10-05 08:30:14 ghd $
 
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
@@ -26,6 +25,7 @@ define KernelPackage/compcache
   VERSION:=$(LINUX_VERSION)-$(BOARD)-$(LINUX_RELEASE)+$(PKG_RELEASE)
   FILES:=$(PKG_BUILD_DIR)/ramzswap.$(LINUX_KMOD_SUFFIX) \
         $(PKG_BUILD_DIR)/sub-projects/compression/lzo-kmod/lzo1x.$(LINUX_KMOD_SUFFIX)
   VERSION:=$(LINUX_VERSION)-$(BOARD)-$(LINUX_RELEASE)+$(PKG_RELEASE)
   FILES:=$(PKG_BUILD_DIR)/ramzswap.$(LINUX_KMOD_SUFFIX) \
         $(PKG_BUILD_DIR)/sub-projects/compression/lzo-kmod/lzo1x.$(LINUX_KMOD_SUFFIX)
+  URL:=http://code.google.com/p/compcache/
   MENU:=1
 endef
 
   MENU:=1
 endef
 
index 5044033a21df133aa082e32e8258dc5c59c599d7..1a4bb91fee889e009620266c993d9d6ce0c63e94 100644 (file)
@@ -21,6 +21,7 @@ define Package/gdb/Default
   SECTION:=utils
   CATEGORY:=Utilities
   DEPENDS:=@!(avr32||cris)
   SECTION:=utils
   CATEGORY:=Utilities
   DEPENDS:=@!(avr32||cris)
+  URL:=http://www.gnu.org/software/gdb/
 endef
 
 define Package/gdb
 endef
 
 define Package/gdb
index da3c64e4ff8f461bf16648e15a595afc5f4c820b..e5b4083ea3a03a331f3e9515279497cc51563539 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,13 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=goldfish-qemu
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=goldfish-qemu
+PKG_REV:=2b8ea29e2bd12f876a4d06647e6077bf72de567e
 PKG_VERSION:=20090429
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=git://android.git.kernel.org/platform/external/qemu
 PKG_SOURCE_PROTO:=git
 PKG_VERSION:=20090429
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=git://android.git.kernel.org/platform/external/qemu
 PKG_SOURCE_PROTO:=git
-PKG_SOURCE_VERSION:=2b8ea29e2bd12f876a4d06647e6077bf72de567e
+PKG_SOURCE_VERSION:=$(PKG_REV)
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
 PKG_TARGETS:=bin
 
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
 PKG_TARGETS:=bin
 
index a5cd221a5a983c14ebd4f881292f2d73d44b29f2..9d20ce0b3a6a4daeac97b1b2c74689c74026a0d7 100644 (file)
@@ -1,5 +1,5 @@
 #
 #
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2009-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -33,7 +33,7 @@ define KernelPackage/ifxmips-dsl-api
   SUBMENU:=Network Devices
   TITLE:=DSL CPE API driver
   URL:=http://www.infineon.com/
   SUBMENU:=Network Devices
   TITLE:=DSL CPE API driver
   URL:=http://www.infineon.com/
-  MAINTAINER:=Infineon Technologies AG / Lantiq / blogic@openwrt.org
+  MAINTAINER:=Infineon Technologies AG / Lantiq / John Crispin <blogic@openwrt.org>
   DEPENDS:=@TARGET_ifxmips @BROKEN
   FILES:=$(PKG_BUILD_DIR)/src/mei/ifxmips_mei.$(LINUX_KMOD_SUFFIX) \
        $(PKG_BUILD_DIR)/src/drv_dsl_cpe_api.$(LINUX_KMOD_SUFFIX) \
   DEPENDS:=@TARGET_ifxmips @BROKEN
   FILES:=$(PKG_BUILD_DIR)/src/mei/ifxmips_mei.$(LINUX_KMOD_SUFFIX) \
        $(PKG_BUILD_DIR)/src/drv_dsl_cpe_api.$(LINUX_KMOD_SUFFIX) \
index bd35d2f9c3efd295201d4f0a5551d3db4d4c3231..6fcad6b92f533010c153ded96a7795525f8d5073 100644 (file)
@@ -1,5 +1,5 @@
 #
 #
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2009-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -23,7 +23,7 @@ define Package/ifxmips-dsl-control
   CATEGORY:=Network
   TITLE:=DSL CPE control application
   URL:=http://www.infineon.com/
   CATEGORY:=Network
   TITLE:=DSL CPE control application
   URL:=http://www.infineon.com/
-  MAINTAINER:=Infineon Technologies AG / Lantiq / blogic@openwrt.org
+  MAINTAINER:=Infineon Technologies AG / Lantiq / John Crispin <blogic@openwrt.org>
   DEPENDS:=+kmod-ifxmips-dsl-api +libpthread @BROKEN
 endef
 
   DEPENDS:=+kmod-ifxmips-dsl-api +libpthread @BROKEN
 endef
 
index 75925df550822774babba5f91d5e811affec8332..225c85cf66f35ea9c055650ad2b03661a2927696 100644 (file)
@@ -1,5 +1,5 @@
 # 
 # 
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -35,6 +35,7 @@ define Package/kernel
   DEFAULT:=y
   TITLE:=Virtual kernel package
   VERSION:=$(LINUX_VERSION)-$(LINUX_RELEASE)
   DEFAULT:=y
   TITLE:=Virtual kernel package
   VERSION:=$(LINUX_VERSION)-$(LINUX_RELEASE)
+  URL:=http://www.kernel.org/
 endef
 
 define Package/kernel/install
 endef
 
 define Package/kernel/install
index 35cb8455116c61a0749d117cd44f7965b413297f..de3ecea22cc85ec26afdbb3768b708eac61f3f67 100644 (file)
@@ -1,5 +1,5 @@
 #
 #
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -19,6 +19,7 @@ define Package/ocf-crypto-headers
   CATEGORY:=Utilities
   TITLE:=OCF-Linux cryptodev header
   PKGARCH:=all
   CATEGORY:=Utilities
   TITLE:=OCF-Linux cryptodev header
   PKGARCH:=all
+  URL:=http://ocf-linux.sourceforge.net/
 endef
 
 define Build/Configure
 endef
 
 define Build/Configure
index c18aec871d6faeac55ea868896bd97eb719bc6a8..dfba29a2510ee6bfea0c9ddc0220febbae5d36d0 100644 (file)
@@ -1,5 +1,5 @@
 #
 #
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,14 +8,15 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ps3-utils
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ps3-utils
-PKG_VERSION:=6488134e48cf2d6f2d6471ced8346ac8cb1b855a
+PKG_REV:=6488134e48cf2d6f2d6471ced8346ac8cb1b855a
+PKG_VERSION:=20090320
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.kernel.org/pub/scm/linux/kernel/git/geoff/ps3-utils.git
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.kernel.org/pub/scm/linux/kernel/git/geoff/ps3-utils.git
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=$(PKG_VERSION)
+PKG_SOURCE_VERSION:=$(PKG_REV)
 
 PKG_FIXUP:=libtool
 PKG_INSTALL=1
 
 PKG_FIXUP:=libtool
 PKG_INSTALL=1
index 91ad73b7d0aae250bee8f1c737c9b175ea2cf42c..fe95d89ca9c31b5f7348e9139408659f1e3837e0 100644 (file)
@@ -21,6 +21,7 @@ define Package/uboot-envtools
   CATEGORY:=Utilities
   TITLE:=read/modify U-Boot bootloader environment
   DEPENDS:= @LINUX_2_6 +zlib
   CATEGORY:=Utilities
   TITLE:=read/modify U-Boot bootloader environment
   DEPENDS:= @LINUX_2_6 +zlib
+  URL:=http://www.denx.de/wiki/U-Boot
 endef
 
 define Package/uboot-envtools/description
 endef
 
 define Package/uboot-envtools/description
index b7820a712b2e2e214d48f60f3233ea010ed36b94..893fbf53105ee81f580d56c82f6d6fa0aa379216 100644 (file)
@@ -1,5 +1,5 @@
 #
 #
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -51,7 +51,7 @@ define Package/uboot-xburst-$(1)
   CATEGORY:=Boot Loaders
   DEPENDS:=@TARGET_xburst
   TITLE:=$(2)
   CATEGORY:=Boot Loaders
   DEPENDS:=@TARGET_xburst
   TITLE:=$(2)
-  URL:=http://www.denx.de/wiki/UBoot/WebHome
+  URL:=http://www.denx.de/wiki/U-Boot
   VARIANT:=$(1)
 endef
 endef
   VARIANT:=$(1)
 endef
 endef