- corrected inclusion of Package/vim/Default
authorTravis Kemen <thepeople@openwrt.org>
Thu, 22 May 2008 02:55:08 +0000 (02:55 +0000)
committerTravis Kemen <thepeople@openwrt.org>
Thu, 22 May 2008 02:55:08 +0000 (02:55 +0000)
- removed unused/broken Package/vim-full/postinst and Package/vim/postinst
Signed-off-by: Patrick Scharrenberg <pittipatti@web.de>
SVN-Revision: 11234

utils/vim/Makefile

index 92e204cd4a4466d76415c26a8b3dc80378fc1ea6..e388d44ce25cf936911b8cd836aad4979885fdf3 100644 (file)
@@ -30,22 +30,22 @@ define Package/vim/Default
 endef
 
 define Package/vim
 endef
 
 define Package/vim
-  $(call Packages/vim/Default)
+  $(call Package/vim/Default)
   TITLE+= (Tiny)
 endef
 
 define Package/vim-full
   TITLE+= (Tiny)
 endef
 
 define Package/vim-full
-  $(call Packages/vim/Default)
+  $(call Package/vim/Default)
   TITLE+= (Normal)
 endef
 
 define Package/vim-runtime
   TITLE+= (Normal)
 endef
 
 define Package/vim-runtime
-  $(call Packages/vim/Default)
+  $(call Package/vim/Default)
   TITLE+= (runtime files)
 endef
 
 define Package/vim-help
   TITLE+= (runtime files)
 endef
 
 define Package/vim-help
-  $(call Packages/vim/Default)
+  $(call Package/vim/Default)
   TITLE+= (help files)
 endef
 
   TITLE+= (help files)
 endef
 
@@ -155,28 +155,6 @@ define Package/vim-help/install
        tar -C $(1) -xzf $(PKG_BUILD_DIR)/docs.tgz 
 endef
 
        tar -C $(1) -xzf $(PKG_BUILD_DIR)/docs.tgz 
 endef
 
-define Package/vim-full/postinst
-#!/bin/sh
-  if [ $${IPKG_INSTROOT} != / ]
-  then
-    if [ -d /usr/share/ ]
-      then
-        ln -s $${IPKG_INSTROOT}/usr/share/vim/ /usr/share/
-    fi
-  fi
-endef
-
-define Package/vim/postinst
-#!/bin/sh
-  if [ $${IPKG_INSTROOT} != / ]
-  then
-    if [ -d /usr/share/ ]
-      then
-        ln -s $${IPKG_INSTROOT}/usr/share/vim/vimrc /usr/share/vim/vimrc
-    fi
-  fi
-endef
-
 $(eval $(call BuildPackage,vim))
 $(eval $(call BuildPackage,vim-full))
 $(eval $(call BuildPackage,vim-runtime))
 $(eval $(call BuildPackage,vim))
 $(eval $(call BuildPackage,vim-full))
 $(eval $(call BuildPackage,vim-runtime))