[packages] add basic sslh (SSL/SSH multiplexer), uci config support welcome :) (close...
authorNicolas Thill <nico@openwrt.org>
Mon, 9 Mar 2009 16:04:28 +0000 (16:04 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 9 Mar 2009 16:04:28 +0000 (16:04 +0000)
SVN-Revision: 14818

net/sslh/Makefile [new file with mode: 0644]

diff --git a/net/sslh/Makefile b/net/sslh/Makefile
new file mode 100644 (file)
index 0000000..8641a60
--- /dev/null
@@ -0,0 +1,42 @@
+# 
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=sslh
+PKG_VERSION:=1.6g
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://rutschle.net/tech/
+PKG_MD5SUM:=dc27a0fbcc9b3e434c203df7bc3c283a
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/sslh
+  SECTION:=net
+  CATEGORY:=Network
+  TITLE:=SSL/SSH multiplexer
+  URL:=http://rutschle.net/tech/sslh.shtml
+endef
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               CC="$(TARGET_CC)" \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               USELIBWRAP= \
+               all
+endef
+
+define Package/sslh/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/sslh $(1)/usr/sbin/
+endef
+
+$(eval $(call BuildPackage,sslh))
+