kernel: generic: Update 2.6.39 to final
authorHauke Mehrtens <hauke@hauke-m.de>
Wed, 25 May 2011 19:51:40 +0000 (19:51 +0000)
committerHauke Mehrtens <hauke@hauke-m.de>
Wed, 25 May 2011 19:51:40 +0000 (19:51 +0000)
* Add missing config symbols
* Update package/kernel for 2.6.39

CONFIG_BT_L2CAP=y and CONFIG_BT_SCO=y are set to build them into the bluetooth module.

Thank you Jonas Gorski for the patch

SVN-Revision: 27010

package/kernel/modules/netsupport.mk
package/kernel/modules/other.mk
package/kernel/modules/usb.mk
package/kernel/modules/virtual.mk
target/linux/generic/config-2.6.39

index a1518156faf494f184e15d3e184b40f42d4b36ba..7387319731b04d5e3ec4b85f704c753229115614 100644 (file)
@@ -477,7 +477,7 @@ $(eval $(call KernelPackage,pppoa))
 define KernelPackage/pptp
   SUBMENU:=$(NETWORK_SUPPORT_MENU)
   TITLE:=PPtP support
-  DEPENDS:=kmod-ppp +kmod-gre @LINUX_2_6_37||LINUX_2_6_38
+  DEPENDS:=kmod-ppp +kmod-gre @LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39
   KCONFIG:=CONFIG_PPTP
   FILES:=$(LINUX_DIR)/drivers/net/pptp.ko
   AUTOLOAD:=$(call AutoLoad,41,pptp)
@@ -489,9 +489,9 @@ $(eval $(call KernelPackage,pptp))
 define KernelPackage/pppol2tp
   SUBMENU:=$(NETWORK_SUPPORT_MENU)
   TITLE:=PPPoL2TP support
-  DEPENDS:=kmod-ppp +kmod-pppoe +LINUX_2_6_35||LINUX_2_6_36||LINUX_2_6_37||LINUX_2_6_38:kmod-l2tp
+  DEPENDS:=kmod-ppp +kmod-pppoe +LINUX_2_6_35||LINUX_2_6_36||LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39:kmod-l2tp
   KCONFIG:=CONFIG_PPPOL2TP
-  ifneq ($(CONFIG_LINUX_2_6_35)$(CONFIG_LINUX_2_6_36)$(CONFIG_LINUX_2_6_37)$(CONFIG_LINUX_2_6_38),)
+  ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.35)),1)
     FILES:=$(LINUX_DIR)/net/l2tp/l2tp_ppp.ko
     AUTOLOAD:=$(call AutoLoad,40,l2tp_ppp)
   else
@@ -652,7 +652,7 @@ $(eval $(call KernelPackage,pktgen))
 
 define KernelPackage/l2tp
   SUBMENU:=$(NETWORK_SUPPORT_MENU)
-  DEPENDS:=@LINUX_2_6_35||LINUX_2_6_36||LINUX_2_6_37||LINUX_2_6_38
+  DEPENDS:=@LINUX_2_6_35||LINUX_2_6_36||LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39
   TITLE:=Layer Two Tunneling Protocol (L2TP)
   KCONFIG:=CONFIG_L2TP \
        CONFIG_L2TP_V3=y \
index 5ab43368eeb0ad3ef16f775c4f8d0bd7242193c1..3e17dc345db5118aa5c0ff48dff49a6357a81279 100644 (file)
@@ -38,14 +38,19 @@ define KernelPackage/bluetooth
   $(call AddDepends/rfkill)
   FILES:= \
        $(LINUX_DIR)/net/bluetooth/bluetooth.ko \
-       $(LINUX_DIR)/net/bluetooth/l2cap.ko \
-       $(LINUX_DIR)/net/bluetooth/sco.ko \
        $(LINUX_DIR)/net/bluetooth/rfcomm/rfcomm.ko \
        $(LINUX_DIR)/net/bluetooth/bnep/bnep.ko \
        $(LINUX_DIR)/net/bluetooth/hidp/hidp.ko \
        $(LINUX_DIR)/drivers/bluetooth/hci_uart.ko \
        $(LINUX_DIR)/drivers/bluetooth/btusb.ko
-  AUTOLOAD:=$(call AutoLoad,90,bluetooth l2cap sco rfcomm bnep hidp hci_uart btusb)
+  ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.39)),1)
+    AUTOLOAD:=$(call AutoLoad,90,bluetooth rfcomm bnep hidp hci_uart btusb)
+  else
+    FILES+= \
+       $(LINUX_DIR)/net/bluetooth/l2cap.ko \
+       $(LINUX_DIR)/net/bluetooth/sco.ko
+    AUTOLOAD:=$(call AutoLoad,90,bluetooth l2cap sco rfcomm bnep hidp hci_uart btusb)
+  endif
 endef
 
 define KernelPackage/bluetooth/description
index e543cd644ec2f5204a50860d2b96938fb4ba7694..587bb8daa48110fad8702aacc1592201cdd08f42 100644 (file)
@@ -546,7 +546,7 @@ $(eval $(call KernelPackage,usb-serial-keyspan))
 
 define KernelPackage/usb-serial-wwan
   TITLE:=Support for GSM and CDMA modems
-  DEPENDS:= @LINUX_2_6_35||LINUX_2_6_36||LINUX_2_6_37||LINUX_2_6_38
+  DEPENDS:= @LINUX_2_6_35||LINUX_2_6_36||LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39
   KCONFIG:=CONFIG_USB_SERIAL_WWAN
   FILES:=$(LINUX_DIR)/drivers/usb/serial/usb_wwan.ko
   AUTOLOAD:=$(call AutoLoad,61,usb_wwan)
@@ -562,7 +562,7 @@ $(eval $(call KernelPackage,usb-serial-wwan))
 
 define KernelPackage/usb-serial-option
   TITLE:=Support for Option HSDPA modems
-  DEPENDS:=+LINUX_2_6_35||LINUX_2_6_36||LINUX_2_6_37||LINUX_2_6_38:kmod-usb-serial-wwan
+  DEPENDS:=+LINUX_2_6_35||LINUX_2_6_36||LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39:kmod-usb-serial-wwan
   KCONFIG:=CONFIG_USB_SERIAL_OPTION
   FILES:=$(LINUX_DIR)/drivers/usb/serial/option.ko
   AUTOLOAD:=$(call AutoLoad,65,option)
index 8f9261acdbd63c1766a922cc20b48a45a47fc316..3e243585b87948bd5496e06402df67076035237f 100644 (file)
@@ -166,7 +166,7 @@ $(eval $(call KernelPackage,xen-netdev))
 define KernelPackage/xen-pcidev
   SUBMENU:=$(VIRTUAL_MENU)
   TITLE:=Xen PCI device frontend
-  DEPENDS:=@TARGET_x86_xen_domu @LINUX_2_6_37||LINUX_2_6_38
+  DEPENDS:=@TARGET_x86_xen_domu @LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39
   KCONFIG:=CONFIG_XEN_PCIDEV_FRONTEND
   FILES:=$(LINUX_DIR)/drivers/xen/platform-pci.ko
   AUTOLOAD:=$(call AutoLoad,10,xen-pcifront)
index 82fe830feda67fdce9165cd3fdf039ee6537413b..d0f80516f1d4c41aa7043f22f518fe80acf0981a 100644 (file)
@@ -28,6 +28,7 @@ CONFIG_AIO=y
 # CONFIG_AIRO_CS is not set
 # CONFIG_ALCHEMY_GPIO_INDIRECT is not set
 # CONFIG_ALIM7101_WDT is not set
+# CONFIG_ALTERA_STAPL is not set
 # CONFIG_AMD8111_ETH is not set
 # CONFIG_AMIGA_PARTITION is not set
 CONFIG_ANON_INODES=y
@@ -322,11 +323,11 @@ CONFIG_BT_HCIUART_H4=y
 # CONFIG_BT_HCIUART_LL is not set
 # CONFIG_BT_HCIVHCI is not set
 # CONFIG_BT_HIDP is not set
-# CONFIG_BT_L2CAP is not set
+CONFIG_BT_L2CAP=y
 # CONFIG_BT_MRVL is not set
 # CONFIG_BT_RFCOMM is not set
 CONFIG_BT_RFCOMM_TTY=y
-# CONFIG_BT_SCO is not set
+CONFIG_BT_SCO=y
 CONFIG_BUG=y
 # CONFIG_C2PORT is not set
 # CONFIG_CAIF is not set
@@ -552,6 +553,7 @@ CONFIG_DEVPORT=y
 # CONFIG_DMA_ENGINE is not set
 # CONFIG_DM_LOG_USERSPACE is not set
 # CONFIG_DM_RAID is not set
+# CONFIG_DM_FLAKEY is not set
 # CONFIG_DNET is not set
 # CONFIG_DNOTIFY is not set
 # CONFIG_DRAGONRISE_FF is not set
@@ -779,7 +781,9 @@ CONFIG_HAVE_KRETPROBES=y
 # CONFIG_HID_GREENASIA is not set
 # CONFIG_HID_GYRATION is not set
 # CONFIG_HID_KENSINGTON is not set
+# CONFIG_HID_KEYTOUCH is not set
 # CONFIG_HID_KYE is not set
+# CONFIG_HID_LCPOWER is not set
 # CONFIG_HID_LOGITECH is not set
 # CONFIG_HID_MAGICMOUSE is not set
 # CONFIG_HID_MICROSOFT is not set
@@ -795,8 +799,10 @@ CONFIG_HAVE_KRETPROBES=y
 # CONFIG_HID_PRODIKEYS is not set
 # CONFIG_HID_QUANTA is not set
 # CONFIG_HID_ROCCAT is not set
+# CONFIG_HID_ROCCAT_ARVO is not set
 # CONFIG_HID_ROCCAT_KONE is not set
 # CONFIG_HID_ROCCAT_KONEPLUS is not set
+# CONFIG_HID_ROCCAT_KOVAPLUS is not set
 # CONFIG_HID_ROCCAT_PYRA is not set
 # CONFIG_HID_SAMSUNG is not set
 # CONFIG_HID_SMARTJOYPLUS is not set
@@ -867,6 +873,7 @@ CONFIG_HZ_100=y
 # CONFIG_I2C_DEBUG_BUS is not set
 # CONFIG_I2C_DEBUG_CORE is not set
 # CONFIG_I2C_DESIGNWARE is not set
+# CONFIG_I2C_DIOLAN_U2C is not set
 # CONFIG_I2C_EG20T is not set
 # CONFIG_I2C_ELEKTOR is not set
 # CONFIG_I2C_GPIO is not set
@@ -1025,6 +1032,7 @@ CONFIG_INPUT_MISC=y
 CONFIG_IOSCHED_DEADLINE=y
 CONFIG_IOSCHED_NOOP=y
 # CONFIG_IP_FIB_TRIE_STATS is not set
+# CONFIG_IP_SET is not set
 # CONFIG_IP1000 is not set
 # CONFIG_IP17XX_PHY is not set
 # CONFIG_IP6_NF_FILTER is not set
@@ -1195,6 +1203,7 @@ CONFIG_KERNEL_LZMA=y
 # CONFIG_KEYBOARD_MCS is not set
 # CONFIG_KEYBOARD_NEWTON is not set
 # CONFIG_KEYBOARD_OPENCORES is not set
+# CONFIG_KEYBOARD_QT1070 is not set
 # CONFIG_KEYBOARD_QT2160 is not set
 # CONFIG_KEYBOARD_STOWAWAY is not set
 # CONFIG_KEYBOARD_SUNKBD is not set
@@ -1225,6 +1234,7 @@ CONFIG_LEDS_CLASS=y
 # CONFIG_LEDS_DAC124S085 is not set
 CONFIG_LEDS_GPIO_PLATFORM=y
 # CONFIG_LEDS_INTEL_SS4200 is not set
+# CONFIG_LEDS_LM3530 is not set
 # CONFIG_LEDS_LP3944 is not set
 # CONFIG_LEDS_LP5521 is not set
 # CONFIG_LEDS_LP5523 is not set
@@ -1299,6 +1309,7 @@ CONFIG_LZMA_DECOMPRESS=y
 # CONFIG_MD is not set
 # CONFIG_MDIO_BITBANG is not set
 # CONFIG_MEDIA_ATTACH is not set
+# CONFIG_MEDIA_CONTROLLER is not set
 # CONFIG_MEDIA_SUPPORT is not set
 # CONFIG_MEDIA_TUNER_CUSTOMISE is not set
 # CONFIG_MEGARAID_LEGACY is not set
@@ -1334,6 +1345,7 @@ CONFIG_MFD_SUPPORT=y
 # CONFIG_MFD_WM8350_I2C is not set
 # CONFIG_MFD_WM8400 is not set
 # CONFIG_MFD_WM8994 is not set
+# CONFIG_MFD_WL1273_CORE is not set
 # CONFIG_MG_DISK is not set
 # CONFIG_MICREL_PHY is not set
 # CONFIG_MIGRATION is not set
@@ -1787,6 +1799,7 @@ CONFIG_PAGE_SIZE_4KB=y
 CONFIG_PARTITION_ADVANCED=y
 # CONFIG_PATA_ALI is not set
 # CONFIG_PATA_AMD is not set
+# CONFIG_PATA_ARASAN_CF is not set
 # CONFIG_PATA_ARTOP is not set
 # CONFIG_PATA_ATIIXP is not set
 # CONFIG_PATA_ATP867X is not set
@@ -1884,6 +1897,7 @@ CONFIG_PCI_SYSCALL=y
 # CONFIG_PLX_HERMES is not set
 # CONFIG_PM is not set
 # CONFIG_PM_RUNTIME is not set
+# CONFIG_PMBUS is not set
 # CONFIG_PMC_MSP is not set
 # CONFIG_PMC_YOSEMITE is not set
 # CONFIG_PMIC_ADP5520 is not set
@@ -2060,6 +2074,7 @@ CONFIG_RTC_LIB=y
 # CONFIG_RTL8366S_PHY is not set
 # CONFIG_RTL8366S_PHY_DEBUG_FS is not set
 # CONFIG_RTL8366_SMI is not set
+# CONFIG_RTS_PSTOR is not set
 CONFIG_RT_MUTEXES=y
 # CONFIG_RT_MUTEX_TESTER is not set
 # CONFIG_RUNTIME_DEBUG is not set
@@ -2184,6 +2199,7 @@ CONFIG_SELECT_MEMORY_MODEL=y
 # CONFIG_SENSORS_ADM1029 is not set
 # CONFIG_SENSORS_ADM1031 is not set
 # CONFIG_SENSORS_ADM9240 is not set
+# CONFIG_SENSORS_ADS1015 is not set
 # CONFIG_SENSORS_ADS7828 is not set
 # CONFIG_SENSORS_ADS7871 is not set
 # CONFIG_SENSORS_ADT7411 is not set
@@ -2218,6 +2234,7 @@ CONFIG_SELECT_MEMORY_MODEL=y
 # CONFIG_SENSORS_IT87 is not set
 # CONFIG_SENSORS_JC42 is not set
 # CONFIG_SENSORS_K8TEMP is not set
+# CONFIG_SENSORS_LINEAGE is not set
 # CONFIG_SENSORS_LIS3LV02D is not set
 # CONFIG_SENSORS_LIS3_I2C is not set
 # CONFIG_SENSORS_LIS3_SPI is not set
@@ -2235,15 +2252,18 @@ CONFIG_SELECT_MEMORY_MODEL=y
 # CONFIG_SENSORS_LM92 is not set
 # CONFIG_SENSORS_LM93 is not set
 # CONFIG_SENSORS_LM95241 is not set
+# CONFIG_SENSORS_LTC4151 is not set
 # CONFIG_SENSORS_LTC4215 is not set
 # CONFIG_SENSORS_LTC4245 is not set
 # CONFIG_SENSORS_LTC4261 is not set
 # CONFIG_SENSORS_MAX1111 is not set
 # CONFIG_SENSORS_MAX1619 is not set
+# CONFIG_SENSORS_MAX6639 is not set
 # CONFIG_SENSORS_MAX6650 is not set
 # CONFIG_SENSORS_PC87360 is not set
 # CONFIG_SENSORS_PC87427 is not set
 # CONFIG_SENSORS_PCF8591 is not set
+# CONFIG_SENSORS_SCH5627 is not set
 # CONFIG_SENSORS_SHT15 is not set
 # CONFIG_SENSORS_SHT21 is not set
 # CONFIG_SENSORS_SIS5595 is not set
@@ -2459,6 +2479,7 @@ CONFIG_SND_PCM_OSS_PLUGINS=y
 # CONFIG_SND_TIMER is not set
 # CONFIG_SND_TRIDENT is not set
 CONFIG_SND_USB=y
+# CONFIG_SND_USB_6FIRE is not set
 # CONFIG_SND_USB_AUDIO is not set
 # CONFIG_SND_USB_CAIAQ is not set
 # CONFIG_SND_USB_UA101 is not set
@@ -2629,6 +2650,7 @@ CONFIG_TMPFS=y
 # CONFIG_TOUCHSCREEN_USB_COMPOSITE is not set
 # CONFIG_TOUCHSCREEN_W90X900 is not set
 # CONFIG_TOUCHSCREEN_WACOM_W8001 is not set
+# CONFIG_TPS6105X is not set
 # CONFIG_TPS65010 is not set
 # CONFIG_TPS6507X is not set
 # CONFIG_TR is not set
@@ -2704,6 +2726,7 @@ CONFIG_USB_EZUSB=y
 # CONFIG_USB_GSPCA_KONICA is not set
 # CONFIG_USB_GSPCA_MARS is not set
 # CONFIG_USB_GSPCA_MR97310A is not set
+# CONFIG_USB_GSPCA_NW80X is not set
 # CONFIG_USB_GSPCA_OV519 is not set
 # CONFIG_USB_GSPCA_OV534 is not set
 # CONFIG_USB_GSPCA_OV534_9 is not set
@@ -2730,6 +2753,7 @@ CONFIG_USB_EZUSB=y
 # CONFIG_USB_GSPCA_T613 is not set
 # CONFIG_USB_GSPCA_TV8532 is not set
 # CONFIG_USB_GSPCA_VC032X is not set
+# CONFIG_USB_GSPCA_VICAM is not set
 # CONFIG_USB_GSPCA_XIRLINK_CIT is not set
 # CONFIG_USB_GSPCA_ZC3XX is not set
 # CONFIG_USB_G_MULTI is not set
@@ -2900,6 +2924,7 @@ CONFIG_USB_STORAGE_USBAT=y
 # CONFIG_USB_VICAM is not set
 # CONFIG_USB_VIDEO_CLASS is not set
 CONFIG_USB_VIDEO_CLASS_INPUT_EVDEV=y
+# CONFIG_USB_VL600 is not set
 # CONFIG_USB_WDM is not set
 # CONFIG_USB_WHCI_HCD is not set
 # CONFIG_USB_WUSB is not set
@@ -2960,6 +2985,7 @@ CONFIG_USB_VIDEO_CLASS_INPUT_EVDEV=y
 # CONFIG_VIDEO_MSP3400 is not set
 # CONFIG_VIDEO_MT9V011 is not set
 # CONFIG_VIDEO_MXB is not set
+# CONFIG_VIDEO_NOON010PC30 is not set
 # CONFIG_VIDEO_OUTPUT_CONTROL is not set
 # CONFIG_VIDEO_OV7670 is not set
 # CONFIG_VIDEO_PMS is not set