at91: bump to v3.18
authorJohn Crispin <john@openwrt.org>
Wed, 18 Feb 2015 13:35:46 +0000 (13:35 +0000)
committerJohn Crispin <john@openwrt.org>
Wed, 18 Feb 2015 13:35:46 +0000 (13:35 +0000)
Signed-off-by: Your Name <blogic@openwrt.org>
SVN-Revision: 44489

13 files changed:
target/linux/at91/Makefile
target/linux/at91/config-default
target/linux/at91/files-3.14/arch/arm/boot/dts/lmu5000.dts [deleted file]
target/linux/at91/files-3.14/drivers/mtd/at91part.c [deleted file]
target/linux/at91/files/arch/arm/boot/dts/lmu5000.dts [new file with mode: 0644]
target/linux/at91/files/drivers/mtd/at91part.c [new file with mode: 0644]
target/linux/at91/patches-3.14/100-ARM-at91-build-dtb-for-LMU5000.patch [deleted file]
target/linux/at91/patches-3.14/805-free_some_portc_pins.patch [deleted file]
target/linux/at91/patches-3.14/901-AT91-flexibity-default-leds-to-heartbeat.patch [deleted file]
target/linux/at91/patches/100-ARM-at91-build-dtb-for-LMU5000.patch [new file with mode: 0644]
target/linux/at91/patches/805-free_some_portc_pins.patch [new file with mode: 0644]
target/linux/at91/patches/901-AT91-flexibity-default-leds-to-heartbeat.patch [new file with mode: 0644]
target/linux/at91/sama5d3/config-default

index 27ee330026f925f2c6b09999a1d98f448cd52e98..040df33300285b359c496c5e550f6f6fd26cd800 100644 (file)
@@ -13,7 +13,7 @@ BOARDNAME:=Atmel AT91
 FEATURES:=squashfs targz ext2 usb
 SUBTARGETS:=legacy sama5d3
 
 FEATURES:=squashfs targz ext2 usb
 SUBTARGETS:=legacy sama5d3
 
-KERNEL_PATCHVER:=3.14
+KERNEL_PATCHVER:=3.18
 
 include $(INCLUDE_DIR)/target.mk
 
 
 include $(INCLUDE_DIR)/target.mk
 
index 6ed83c8e74cb31c739997eb2999bd3bd5b35666a..89a9fc214743c4468ce7efc8aa0a082a1131e7e9 100644 (file)
@@ -171,6 +171,10 @@ CONFIG_PINCTRL=y
 CONFIG_PINCTRL_AT91=y
 # CONFIG_PINCTRL_SINGLE is not set
 CONFIG_PINMUX=y
 CONFIG_PINCTRL_AT91=y
 # CONFIG_PINCTRL_SINGLE is not set
 CONFIG_PINMUX=y
+# CONFIG_PL310_ERRATA_588369 is not set
+# CONFIG_PL310_ERRATA_727915 is not set
+# CONFIG_PL310_ERRATA_753970 is not set
+# CONFIG_PL310_ERRATA_769419 is not set
 # CONFIG_PREEMPT_RCU is not set
 CONFIG_PROC_DEVICETREE=y
 # CONFIG_RCU_STALL_COMMON is not set
 # CONFIG_PREEMPT_RCU is not set
 CONFIG_PROC_DEVICETREE=y
 # CONFIG_RCU_STALL_COMMON is not set
@@ -210,6 +214,7 @@ CONFIG_USB_ETH=y
 # CONFIG_USB_ETH_EEM is not set
 CONFIG_USB_ETH_RNDIS=y
 CONFIG_USB_GADGET=y
 # CONFIG_USB_ETH_EEM is not set
 CONFIG_USB_ETH_RNDIS=y
 CONFIG_USB_GADGET=y
+# CONFIG_USB_GADGET_XILINX is not set
 CONFIG_USB_LIBCOMPOSITE=y
 CONFIG_USB_SUPPORT=y
 CONFIG_USE_OF=y
 CONFIG_USB_LIBCOMPOSITE=y
 CONFIG_USB_SUPPORT=y
 CONFIG_USE_OF=y
diff --git a/target/linux/at91/files-3.14/arch/arm/boot/dts/lmu5000.dts b/target/linux/at91/files-3.14/arch/arm/boot/dts/lmu5000.dts
deleted file mode 100644 (file)
index 921d44b..0000000
+++ /dev/null
@@ -1,125 +0,0 @@
-/*
- * lmu5000.dst - Device Tree file for CalAmp LMU5000 board
- *
- * Copyright (C) 2013 Adam Porter <porter.adam@gmail.com>
- *
- * Licensed under GPLv2.
- */
-/dts-v1/;
-#include "at91sam9g20.dtsi"
-
-/ {
-       model = "CalAmp LMU5000";
-       compatible = "calamp,lmu5000", "atmel,at91sam9g20", "atmel,at91sam9";
-
-       chosen {
-               bootargs = "mem=64M console=ttyS0,115200 rootfstype=jffs2";
-       };
-
-       memory {
-               reg = <0x20000000 0x4000000>;
-       };
-
-       clocks {
-               #address-cells = <1>;
-               #size-cells = <1>;
-               ranges;
-
-               main_clock: clock@0 {
-                       compatible = "atmel,osc", "fixed-clock";
-                       clock-frequency = <18432000>;
-               };
-       };
-
-       ahb {
-               apb {
-                       pinctrl@fffff400 {
-                               board {
-                                       pinctrl_pck0_as_mck: pck0_as_mck {
-                                               atmel,pins =
-                                                       <2 1 0x2 0x0>;  /* PC1 periph B */
-                                       };
-
-                               };
-                       };
-
-                       dbgu: serial@fffff200 {
-                               status = "okay";
-                       };
-
-                       usart0: serial@fffb0000 {
-                               pinctrl-0 =
-                                       <&pinctrl_usart0
-                                        &pinctrl_usart0_rts
-                                        &pinctrl_usart0_cts
-                                        &pinctrl_usart0_dtr_dsr
-                                        &pinctrl_usart0_dcd
-                                        &pinctrl_usart0_ri>;
-                               status = "okay";
-                       };
-
-                       usart2: serial@fffb8000 {
-                               status = "okay";
-                       };
-
-                       uart0: serial@fffd4000 {
-                               status = "okay";
-                       };
-
-                       uart1: serial@fffd8000 {
-                               status = "okay";
-                       };
-
-                       macb0: ethernet@fffc4000 {
-                               phy-mode = "mii";
-                               status = "okay";
-                       };
-
-                       usb1: gadget@fffa4000 {
-                               atmel,vbus-gpio = <&pioC 5 0>;
-                               status = "okay";
-                       };
-
-                       ssc0: ssc@fffbc000 {
-                               status = "okay";
-                               pinctrl-0 = <&pinctrl_ssc0_tx>;
-                       };
-
-                       watchdog@fffffd40 {
-                               status = "okay";
-                       };
-               };
-
-               nand0: nand@40000000 {
-                       nand-bus-width = <8>;
-                       nand-ecc-mode = "soft";
-                       nand-on-flash-bbt;
-                       status = "okay";
-
-                       kernel@0 {
-                               label = "kernel";
-                               reg = <0x0 0x400000>;
-                       };
-
-                       rootfs@400000 {
-                               label = "rootfs";
-                               reg = <0x400000 0x3C00000>;
-                       };
-
-                       user1@4000000 {
-                               label = "user1";
-                               reg = <0x4000000 0x2000000>;
-                       };
-
-                       user2@6000000 {
-                               label = "user2";
-                               reg = <0x6000000 0x2000000>;
-                       };
-               };
-
-               usb0: ohci@00500000 {
-                       num-ports = <2>;
-                       status = "okay";
-               };
-       };
-};
diff --git a/target/linux/at91/files-3.14/drivers/mtd/at91part.c b/target/linux/at91/files-3.14/drivers/mtd/at91part.c
deleted file mode 100644 (file)
index 31f3bbd..0000000
+++ /dev/null
@@ -1,122 +0,0 @@
-/*
- * 
- * Copyright (C) 2007 OpenWrt.org
- * 
- * This program is free software; you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation; either version 2 of the License, or
- * (at your option) any later version.
- * 
- * This program is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
- * GNU General Public License for more details.
- * 
- * You should have received a copy of the GNU General Public License
- * along with this program; if not, write to the Free Software
- * Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA  02110-1301  USA
- *
- * Atmel AT91 flash partition table. (Modified by Hamish Guthrie).
- * Based on ar7 map by Felix Fietkau.
- *
- */
-
-#include <linux/kernel.h>
-#include <linux/slab.h>
-
-#include <linux/mtd/mtd.h>
-#include <linux/mtd/partitions.h>
-#include <linux/bootmem.h>
-#include <linux/squashfs_fs.h>
-
-static struct mtd_partition at91_parts[6];
-
-static int create_mtd_partitions(struct mtd_info *master, 
-                                struct mtd_partition **pparts, 
-                                unsigned long origin)
-{
-       unsigned int offset, len;
-       unsigned int pre_size = 0x42000, root_max = 0x362400;
-       unsigned char buf[512];
-       struct squashfs_super_block *sb = (struct squashfs_super_block *) buf;
-
-       printk("Parsing AT91 partition map...\n");
-
-       at91_parts[0].name = "loaders";
-       at91_parts[0].offset = 0;
-       at91_parts[0].size = 0x21000;
-       at91_parts[0].mask_flags = MTD_WRITEABLE;
-
-       at91_parts[1].name = "ubparams";
-       at91_parts[1].offset = 0x21000;
-       at91_parts[1].size = 0x8400;
-       at91_parts[1].mask_flags = 0;
-
-       at91_parts[2].name = "kernel";
-       at91_parts[2].offset = pre_size;
-       at91_parts[2].size = 0;
-       at91_parts[2].mask_flags = 0;
-
-       at91_parts[3].name = "rootfs";
-       at91_parts[3].offset = 0;
-       at91_parts[3].size = 0;
-       at91_parts[3].mask_flags = 0;
-
-       for(offset = pre_size; offset < root_max; offset += master->erasesize) {
-
-               memset(&buf, 0xe5, sizeof(buf));
-
-               if (master->read(master, offset, sizeof(buf), &len, buf) || len != sizeof(buf))
-                       break;
-
-               if (*((__u32 *) buf) == SQUASHFS_MAGIC) {
-                       printk(KERN_INFO "%s: Filesystem type: squashfs, size=0x%x\n",
-                                                       master->name, (u32) sb->bytes_used);
-
-                       at91_parts[3].size = sb->bytes_used;
-                       at91_parts[3].offset = offset;
-                       len = at91_parts[3].offset + at91_parts[3].size;
-                       len = ((len / (master->erasesize * 8)) + 1) * master->erasesize * 8;
-                       at91_parts[3].size = len - at91_parts[3].offset;
-                       at91_parts[2].size = offset - at91_parts[2].offset;
-                       break;
-                       }
-               }
-
-       if (at91_parts[3].size == 0) {
-               printk(KERN_NOTICE "%s: Couldn't find root filesystem\n", master->name);
-               return -1;
-               }
-
-       at91_parts[4].name = "rootfs_data";
-       at91_parts[4].offset = root_max;
-       at91_parts[4].size = master->size - root_max;
-       at91_parts[4].mask_flags = 0;
-
-       at91_parts[5].name = "complete";
-       at91_parts[5].offset = 0;
-       at91_parts[5].size = master->size;
-       at91_parts[5].mask_flags = 0;
-
-       *pparts = at91_parts;
-       return 6;
-}
-
-static struct mtd_part_parser at91_parser = {
-       .owner = THIS_MODULE,
-       .parse_fn = create_mtd_partitions,
-       .name = "at91part",
-};
-
-static int __init at91_parser_init(void)
-{
-       register_mtd_parser(&at91_parser);
-
-       return 0;
-}
-
-module_init(at91_parser_init);
-
-MODULE_LICENSE("GPL");
-MODULE_AUTHOR("Felix Fietkau, Eugene Konev, Hamish Guthrie");
-MODULE_DESCRIPTION("MTD partitioning for Atmel at91");
diff --git a/target/linux/at91/files/arch/arm/boot/dts/lmu5000.dts b/target/linux/at91/files/arch/arm/boot/dts/lmu5000.dts
new file mode 100644 (file)
index 0000000..921d44b
--- /dev/null
@@ -0,0 +1,125 @@
+/*
+ * lmu5000.dst - Device Tree file for CalAmp LMU5000 board
+ *
+ * Copyright (C) 2013 Adam Porter <porter.adam@gmail.com>
+ *
+ * Licensed under GPLv2.
+ */
+/dts-v1/;
+#include "at91sam9g20.dtsi"
+
+/ {
+       model = "CalAmp LMU5000";
+       compatible = "calamp,lmu5000", "atmel,at91sam9g20", "atmel,at91sam9";
+
+       chosen {
+               bootargs = "mem=64M console=ttyS0,115200 rootfstype=jffs2";
+       };
+
+       memory {
+               reg = <0x20000000 0x4000000>;
+       };
+
+       clocks {
+               #address-cells = <1>;
+               #size-cells = <1>;
+               ranges;
+
+               main_clock: clock@0 {
+                       compatible = "atmel,osc", "fixed-clock";
+                       clock-frequency = <18432000>;
+               };
+       };
+
+       ahb {
+               apb {
+                       pinctrl@fffff400 {
+                               board {
+                                       pinctrl_pck0_as_mck: pck0_as_mck {
+                                               atmel,pins =
+                                                       <2 1 0x2 0x0>;  /* PC1 periph B */
+                                       };
+
+                               };
+                       };
+
+                       dbgu: serial@fffff200 {
+                               status = "okay";
+                       };
+
+                       usart0: serial@fffb0000 {
+                               pinctrl-0 =
+                                       <&pinctrl_usart0
+                                        &pinctrl_usart0_rts
+                                        &pinctrl_usart0_cts
+                                        &pinctrl_usart0_dtr_dsr
+                                        &pinctrl_usart0_dcd
+                                        &pinctrl_usart0_ri>;
+                               status = "okay";
+                       };
+
+                       usart2: serial@fffb8000 {
+                               status = "okay";
+                       };
+
+                       uart0: serial@fffd4000 {
+                               status = "okay";
+                       };
+
+                       uart1: serial@fffd8000 {
+                               status = "okay";
+                       };
+
+                       macb0: ethernet@fffc4000 {
+                               phy-mode = "mii";
+                               status = "okay";
+                       };
+
+                       usb1: gadget@fffa4000 {
+                               atmel,vbus-gpio = <&pioC 5 0>;
+                               status = "okay";
+                       };
+
+                       ssc0: ssc@fffbc000 {
+                               status = "okay";
+                               pinctrl-0 = <&pinctrl_ssc0_tx>;
+                       };
+
+                       watchdog@fffffd40 {
+                               status = "okay";
+                       };
+               };
+
+               nand0: nand@40000000 {
+                       nand-bus-width = <8>;
+                       nand-ecc-mode = "soft";
+                       nand-on-flash-bbt;
+                       status = "okay";
+
+                       kernel@0 {
+                               label = "kernel";
+                               reg = <0x0 0x400000>;
+                       };
+
+                       rootfs@400000 {
+                               label = "rootfs";
+                               reg = <0x400000 0x3C00000>;
+                       };
+
+                       user1@4000000 {
+                               label = "user1";
+                               reg = <0x4000000 0x2000000>;
+                       };
+
+                       user2@6000000 {
+                               label = "user2";
+                               reg = <0x6000000 0x2000000>;
+                       };
+               };
+
+               usb0: ohci@00500000 {
+                       num-ports = <2>;
+                       status = "okay";
+               };
+       };
+};
diff --git a/target/linux/at91/files/drivers/mtd/at91part.c b/target/linux/at91/files/drivers/mtd/at91part.c
new file mode 100644 (file)
index 0000000..31f3bbd
--- /dev/null
@@ -0,0 +1,122 @@
+/*
+ * 
+ * Copyright (C) 2007 OpenWrt.org
+ * 
+ * This program is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation; either version 2 of the License, or
+ * (at your option) any later version.
+ * 
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+ * GNU General Public License for more details.
+ * 
+ * You should have received a copy of the GNU General Public License
+ * along with this program; if not, write to the Free Software
+ * Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA  02110-1301  USA
+ *
+ * Atmel AT91 flash partition table. (Modified by Hamish Guthrie).
+ * Based on ar7 map by Felix Fietkau.
+ *
+ */
+
+#include <linux/kernel.h>
+#include <linux/slab.h>
+
+#include <linux/mtd/mtd.h>
+#include <linux/mtd/partitions.h>
+#include <linux/bootmem.h>
+#include <linux/squashfs_fs.h>
+
+static struct mtd_partition at91_parts[6];
+
+static int create_mtd_partitions(struct mtd_info *master, 
+                                struct mtd_partition **pparts, 
+                                unsigned long origin)
+{
+       unsigned int offset, len;
+       unsigned int pre_size = 0x42000, root_max = 0x362400;
+       unsigned char buf[512];
+       struct squashfs_super_block *sb = (struct squashfs_super_block *) buf;
+
+       printk("Parsing AT91 partition map...\n");
+
+       at91_parts[0].name = "loaders";
+       at91_parts[0].offset = 0;
+       at91_parts[0].size = 0x21000;
+       at91_parts[0].mask_flags = MTD_WRITEABLE;
+
+       at91_parts[1].name = "ubparams";
+       at91_parts[1].offset = 0x21000;
+       at91_parts[1].size = 0x8400;
+       at91_parts[1].mask_flags = 0;
+
+       at91_parts[2].name = "kernel";
+       at91_parts[2].offset = pre_size;
+       at91_parts[2].size = 0;
+       at91_parts[2].mask_flags = 0;
+
+       at91_parts[3].name = "rootfs";
+       at91_parts[3].offset = 0;
+       at91_parts[3].size = 0;
+       at91_parts[3].mask_flags = 0;
+
+       for(offset = pre_size; offset < root_max; offset += master->erasesize) {
+
+               memset(&buf, 0xe5, sizeof(buf));
+
+               if (master->read(master, offset, sizeof(buf), &len, buf) || len != sizeof(buf))
+                       break;
+
+               if (*((__u32 *) buf) == SQUASHFS_MAGIC) {
+                       printk(KERN_INFO "%s: Filesystem type: squashfs, size=0x%x\n",
+                                                       master->name, (u32) sb->bytes_used);
+
+                       at91_parts[3].size = sb->bytes_used;
+                       at91_parts[3].offset = offset;
+                       len = at91_parts[3].offset + at91_parts[3].size;
+                       len = ((len / (master->erasesize * 8)) + 1) * master->erasesize * 8;
+                       at91_parts[3].size = len - at91_parts[3].offset;
+                       at91_parts[2].size = offset - at91_parts[2].offset;
+                       break;
+                       }
+               }
+
+       if (at91_parts[3].size == 0) {
+               printk(KERN_NOTICE "%s: Couldn't find root filesystem\n", master->name);
+               return -1;
+               }
+
+       at91_parts[4].name = "rootfs_data";
+       at91_parts[4].offset = root_max;
+       at91_parts[4].size = master->size - root_max;
+       at91_parts[4].mask_flags = 0;
+
+       at91_parts[5].name = "complete";
+       at91_parts[5].offset = 0;
+       at91_parts[5].size = master->size;
+       at91_parts[5].mask_flags = 0;
+
+       *pparts = at91_parts;
+       return 6;
+}
+
+static struct mtd_part_parser at91_parser = {
+       .owner = THIS_MODULE,
+       .parse_fn = create_mtd_partitions,
+       .name = "at91part",
+};
+
+static int __init at91_parser_init(void)
+{
+       register_mtd_parser(&at91_parser);
+
+       return 0;
+}
+
+module_init(at91_parser_init);
+
+MODULE_LICENSE("GPL");
+MODULE_AUTHOR("Felix Fietkau, Eugene Konev, Hamish Guthrie");
+MODULE_DESCRIPTION("MTD partitioning for Atmel at91");
diff --git a/target/linux/at91/patches-3.14/100-ARM-at91-build-dtb-for-LMU5000.patch b/target/linux/at91/patches-3.14/100-ARM-at91-build-dtb-for-LMU5000.patch
deleted file mode 100644 (file)
index e8cc68d..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/arch/arm/boot/dts/Makefile
-+++ b/arch/arm/boot/dts/Makefile
-@@ -26,6 +26,7 @@ dtb-$(CONFIG_ARCH_AT91) += usb_a9g20.dtb
- dtb-$(CONFIG_ARCH_AT91) += usb_a9g20_lpw.dtb
- # sam9g45
- dtb-$(CONFIG_ARCH_AT91) += at91sam9m10g45ek.dtb
-+dtb-$(CONFIG_ARCH_AT91) += lmu5000.dtb
- dtb-$(CONFIG_ARCH_AT91) += pm9g45.dtb
- # sam9n12
- dtb-$(CONFIG_ARCH_AT91) += at91sam9n12ek.dtb
diff --git a/target/linux/at91/patches-3.14/805-free_some_portc_pins.patch b/target/linux/at91/patches-3.14/805-free_some_portc_pins.patch
deleted file mode 100644 (file)
index a9694d1..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/arch/arm/mach-at91/at91sam9260_devices.c
-+++ b/arch/arm/mach-at91/at91sam9260_devices.c
-@@ -507,7 +507,7 @@ static struct platform_device at91sam926
-       .num_resources  = ARRAY_SIZE(spi1_resources),
- };
--static const unsigned spi1_standard_cs[4] = { AT91_PIN_PB3, AT91_PIN_PC5, AT91_PIN_PC4, AT91_PIN_PC3 };
-+static const unsigned spi1_standard_cs[2] = { AT91_PIN_PB3, AT91_PIN_PC5 };
- void __init at91_add_device_spi(struct spi_board_info *devices, int nr_devices)
- {
diff --git a/target/linux/at91/patches-3.14/901-AT91-flexibity-default-leds-to-heartbeat.patch b/target/linux/at91/patches-3.14/901-AT91-flexibity-default-leds-to-heartbeat.patch
deleted file mode 100644 (file)
index a97850a..0000000
+++ /dev/null
@@ -1,60 +0,0 @@
---- a/arch/arm/mach-at91/board-flexibity.c
-+++ b/arch/arm/mach-at91/board-flexibity.c
-@@ -89,49 +89,49 @@ static struct gpio_led flexibity_leds[]
-               .name                   = "usb1:green",
-               .gpio                   = AT91_PIN_PA12,
-               .active_low             = 1,
--              .default_trigger        = "default-on",
-+              .default_trigger        = "heartbeat",
-       },
-       {
-               .name                   = "usb1:red",
-               .gpio                   = AT91_PIN_PA13,
-               .active_low             = 1,
--              .default_trigger        = "default-on",
-+              .default_trigger        = "heartbeat",
-       },
-       {
-               .name                   = "usb2:green",
-               .gpio                   = AT91_PIN_PB26,
-               .active_low             = 1,
--              .default_trigger        = "default-on",
-+              .default_trigger        = "heartbeat",
-       },
-       {
-               .name                   = "usb2:red",
-               .gpio                   = AT91_PIN_PB27,
-               .active_low             = 1,
--              .default_trigger        = "default-on",
-+              .default_trigger        = "heartbeat",
-       },
-       {
-               .name                   = "usb3:green",
-               .gpio                   = AT91_PIN_PC8,
-               .active_low             = 1,
--              .default_trigger        = "default-on",
-+              .default_trigger        = "heartbeat",
-       },
-       {
-               .name                   = "usb3:red",
-               .gpio                   = AT91_PIN_PC6,
-               .active_low             = 1,
--              .default_trigger        = "default-on",
-+              .default_trigger        = "heartbeat",
-       },
-       {
-               .name                   = "usb4:green",
-               .gpio                   = AT91_PIN_PB4,
-               .active_low             = 1,
--              .default_trigger        = "default-on",
-+              .default_trigger        = "heartbeat",
-       },
-       {
-               .name                   = "usb4:red",
-               .gpio                   = AT91_PIN_PB5,
-               .active_low             = 1,
--              .default_trigger        = "default-on",
-+              .default_trigger        = "heartbeat",
-       }
- };
diff --git a/target/linux/at91/patches/100-ARM-at91-build-dtb-for-LMU5000.patch b/target/linux/at91/patches/100-ARM-at91-build-dtb-for-LMU5000.patch
new file mode 100644 (file)
index 0000000..e8cc68d
--- /dev/null
@@ -0,0 +1,10 @@
+--- a/arch/arm/boot/dts/Makefile
++++ b/arch/arm/boot/dts/Makefile
+@@ -26,6 +26,7 @@ dtb-$(CONFIG_ARCH_AT91) += usb_a9g20.dtb
+ dtb-$(CONFIG_ARCH_AT91) += usb_a9g20_lpw.dtb
+ # sam9g45
+ dtb-$(CONFIG_ARCH_AT91) += at91sam9m10g45ek.dtb
++dtb-$(CONFIG_ARCH_AT91) += lmu5000.dtb
+ dtb-$(CONFIG_ARCH_AT91) += pm9g45.dtb
+ # sam9n12
+ dtb-$(CONFIG_ARCH_AT91) += at91sam9n12ek.dtb
diff --git a/target/linux/at91/patches/805-free_some_portc_pins.patch b/target/linux/at91/patches/805-free_some_portc_pins.patch
new file mode 100644 (file)
index 0000000..a9694d1
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/arch/arm/mach-at91/at91sam9260_devices.c
++++ b/arch/arm/mach-at91/at91sam9260_devices.c
+@@ -507,7 +507,7 @@ static struct platform_device at91sam926
+       .num_resources  = ARRAY_SIZE(spi1_resources),
+ };
+-static const unsigned spi1_standard_cs[4] = { AT91_PIN_PB3, AT91_PIN_PC5, AT91_PIN_PC4, AT91_PIN_PC3 };
++static const unsigned spi1_standard_cs[2] = { AT91_PIN_PB3, AT91_PIN_PC5 };
+ void __init at91_add_device_spi(struct spi_board_info *devices, int nr_devices)
+ {
diff --git a/target/linux/at91/patches/901-AT91-flexibity-default-leds-to-heartbeat.patch b/target/linux/at91/patches/901-AT91-flexibity-default-leds-to-heartbeat.patch
new file mode 100644 (file)
index 0000000..a97850a
--- /dev/null
@@ -0,0 +1,60 @@
+--- a/arch/arm/mach-at91/board-flexibity.c
++++ b/arch/arm/mach-at91/board-flexibity.c
+@@ -89,49 +89,49 @@ static struct gpio_led flexibity_leds[]
+               .name                   = "usb1:green",
+               .gpio                   = AT91_PIN_PA12,
+               .active_low             = 1,
+-              .default_trigger        = "default-on",
++              .default_trigger        = "heartbeat",
+       },
+       {
+               .name                   = "usb1:red",
+               .gpio                   = AT91_PIN_PA13,
+               .active_low             = 1,
+-              .default_trigger        = "default-on",
++              .default_trigger        = "heartbeat",
+       },
+       {
+               .name                   = "usb2:green",
+               .gpio                   = AT91_PIN_PB26,
+               .active_low             = 1,
+-              .default_trigger        = "default-on",
++              .default_trigger        = "heartbeat",
+       },
+       {
+               .name                   = "usb2:red",
+               .gpio                   = AT91_PIN_PB27,
+               .active_low             = 1,
+-              .default_trigger        = "default-on",
++              .default_trigger        = "heartbeat",
+       },
+       {
+               .name                   = "usb3:green",
+               .gpio                   = AT91_PIN_PC8,
+               .active_low             = 1,
+-              .default_trigger        = "default-on",
++              .default_trigger        = "heartbeat",
+       },
+       {
+               .name                   = "usb3:red",
+               .gpio                   = AT91_PIN_PC6,
+               .active_low             = 1,
+-              .default_trigger        = "default-on",
++              .default_trigger        = "heartbeat",
+       },
+       {
+               .name                   = "usb4:green",
+               .gpio                   = AT91_PIN_PB4,
+               .active_low             = 1,
+-              .default_trigger        = "default-on",
++              .default_trigger        = "heartbeat",
+       },
+       {
+               .name                   = "usb4:red",
+               .gpio                   = AT91_PIN_PB5,
+               .active_low             = 1,
+-              .default_trigger        = "default-on",
++              .default_trigger        = "heartbeat",
+       }
+ };
index 2cdd3819b86e08f080d1c768026e964dc3e13c7d..62aef01668fbbaa5d08dd855eb1b2e2b42953929 100644 (file)
@@ -2,6 +2,7 @@ CONFIG_SOC_SAMA5=y
 # CONFIG_SOC_SAM_V4_V5 is not set
 CONFIG_SOC_SAM_V7=y
 CONFIG_SOC_SAMA5D3=y
 # CONFIG_SOC_SAM_V4_V5 is not set
 CONFIG_SOC_SAM_V7=y
 CONFIG_SOC_SAMA5D3=y
+CONFIG_SOC_SAMA5D4=y
 CONFIG_MACH_SAMA5_DT=y
 # CONFIG_ARM_LPAE is not set
 # CONFIG_ARM_THUMBEE is not set
 CONFIG_MACH_SAMA5_DT=y
 # CONFIG_ARM_LPAE is not set
 # CONFIG_ARM_THUMBEE is not set