fix build where host and target arches are abi compatible (closes: #2411)
authorNicolas Thill <nico@openwrt.org>
Thu, 20 Sep 2007 11:20:41 +0000 (11:20 +0000)
committerNicolas Thill <nico@openwrt.org>
Thu, 20 Sep 2007 11:20:41 +0000 (11:20 +0000)
SVN-Revision: 8873

net/asterisk-addons-1.4.x/Makefile
net/asterisk-addons-1.4.x/patches/021-cross_configure.patch [new file with mode: 0644]

index 1824fac12e8e9aa05b8f6f69332626a35469a8d0..6df3532f82b7410f0cf1c18fed09ff815ca56538 100644 (file)
@@ -79,8 +79,10 @@ $(call Package/asterisk-addons/Default/description)
  This package contains MySQL support modules for Asterisk.
 endef
 
+
 EXTRA_CFLAGS:=$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)
 EXTRA_LDFLAGS:=$(TARGET_LDFLAGS)
+
 ifneq ($(SDK)$(CONFIG_PACKAGE_asterisk14-mysql),)
   EXTRA_CFLAGS+= -I$(STAGING_DIR)/usr/include/mysql
   EXTRA_LDFLAGS+= -L$(STAGING_DIR)/usr/lib/mysql
diff --git a/net/asterisk-addons-1.4.x/patches/021-cross_configure.patch b/net/asterisk-addons-1.4.x/patches/021-cross_configure.patch
new file mode 100644 (file)
index 0000000..42470c7
--- /dev/null
@@ -0,0 +1,12 @@
+diff -ruN asterisk-addons-1.4.2-old/menuselect/Makefile asterisk-addons-1.4.2-new/menuselect/Makefile
+--- asterisk-addons-1.4.2-old/menuselect/Makefile      2007-06-06 00:01:45.000000000 +0200
++++ asterisk-addons-1.4.2-new/menuselect/Makefile      2007-09-19 18:00:27.000000000 +0200
+@@ -42,7 +42,7 @@
+       @$(MAKE) menuselect
+ autoconfig.h:
+-      @./configure $(CONFIGURE_SILENT) CC= LD= AR=
++      @./configure $(CONFIGURE_SILENT) CC= LD= AR= LDFLAGS=
+ _gmenuselect: autoconfig.h 
+       @$(MAKE) gmenuselect