sablevm-sdk: Do not hardcode host paths.
authorMichael Büsch <mb@bu3sch.de>
Sat, 9 Oct 2010 11:05:26 +0000 (11:05 +0000)
committerMichael Büsch <mb@bu3sch.de>
Sat, 9 Oct 2010 11:05:26 +0000 (11:05 +0000)
SVN-Revision: 23358

lang/sablevm-sdk/Makefile

index 94174b11c00f566a615d33a8a10ab1d00a350fde..53497927d784a37ccaa4dc1141fee7de337b2ac0 100644 (file)
@@ -64,8 +64,8 @@ define Build/Configure
        )
        $(call Build/Configure/Default, \
                --srcdir="./../sablevm" \
        )
        $(call Build/Configure/Default, \
                --srcdir="./../sablevm" \
-               --with-fastjar=/usr/bin/fastjar \
-               --with-jikes=/usr/bin/jikes \
+               --with-fastjar=$$$$(which fastjar) \
+               --with-jikes=$$$$(which jikes) \
                --with-internal-libffi=yes \
                --with-internal-libpopt=no \
                ,\
                --with-internal-libffi=yes \
                --with-internal-libpopt=no \
                ,\
@@ -74,8 +74,8 @@ define Build/Configure
        )
        $(call Build/Configure/Default, \
                --srcdir=./../sablevm-classpath \
        )
        $(call Build/Configure/Default, \
                --srcdir=./../sablevm-classpath \
-               --with-fastjar=/usr/bin/fastjar \
-               --with-jikes=/usr/bin/jikes \
+               --with-fastjar=$$$$(which fastjar) \
+               --with-jikes=$$$$(which jikes) \
                --disable-gtk-peer \
                --disable-gtk-cairo \
                --without-x \
                --disable-gtk-peer \
                --disable-gtk-cairo \
                --without-x \