mpc85xx: enable squashfs feature
authorGabor Juhos <juhosg@openwrt.org>
Tue, 19 Feb 2013 14:53:15 +0000 (14:53 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Tue, 19 Feb 2013 14:53:15 +0000 (14:53 +0000)
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
SVN-Revision: 35675

target/linux/mpc85xx/Makefile
target/linux/mpc85xx/image/Makefile

index df8204dba2c36aa4863d621006876f9e8b96a8e6..92064d0dcabfa8c5ff83f1fe1c5e4d830bfee140 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=powerpc
 BOARD:=mpc85xx
 BOARDNAME:=Freescale MPC85xx
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=8540
-FEATURES:=spe_fpu ramdisk
+FEATURES:=spe_fpu squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
 LINUX_VERSION:=3.7.9
index 45cd7abdc2bfee70ce98ee29872abde8a58f7eea..b762515ec3ff4fa68dbfea2609abe53034224239 100644 (file)
@@ -24,6 +24,11 @@ define Image/Build/ext2
        cp $(KDIR)/root.$(1) $(BIN_DIR)/$(IMG_PREFIX)-ext2.img
 endef
 
+define Image/Build/squashfs
+       $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+       cp $(KDIR)/root.squashfs $(BIN_DIR)/$(IMG_PREFIX)-root.squashfs
+endef
+
 define Image/Build
        $(call Image/Build/$(1),$(1))
 endef