fix a race condition with broadcom wl devices in a bridge
authorFelix Fietkau <nbd@openwrt.org>
Wed, 4 Jul 2007 05:05:46 +0000 (05:05 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Wed, 4 Jul 2007 05:05:46 +0000 (05:05 +0000)
if a device is added before the bridge is brought up, the wifi settings are lost

SVN-Revision: 7872

package/base-files/files/lib/network/config.sh

index 2c15b5e..c08fd69 100755 (executable)
@@ -98,6 +98,7 @@ prepare_interface() {
                                } || {
                                        $DEBUG brctl addbr "br-$config"
                                        $DEBUG brctl setfd "br-$config" 0
                                } || {
                                        $DEBUG brctl addbr "br-$config"
                                        $DEBUG brctl setfd "br-$config" 0
+                                       $DEBUG ifconfig "br-$config" up
                                        $DEBUG brctl addif "br-$config" "$iface"
                                        # Creating the bridge here will have triggered a hotplug event, which will
                                        # result in another setup_interface() call, so we simply stop processing
                                        $DEBUG brctl addif "br-$config" "$iface"
                                        # Creating the bridge here will have triggered a hotplug event, which will
                                        # result in another setup_interface() call, so we simply stop processing