ralink: add support for dalink dcs930l ipcam
authorJohn Crispin <john@openwrt.org>
Thu, 19 Sep 2013 05:56:46 +0000 (05:56 +0000)
committerJohn Crispin <john@openwrt.org>
Thu, 19 Sep 2013 05:56:46 +0000 (05:56 +0000)
Signed-off-by: John Crispin <blogic@openwrt.org>
SVN-Revision: 38053

target/linux/ramips/base-files/etc/diag.sh
target/linux/ramips/base-files/etc/hotplug.d/firmware/10-rt2x00-eeprom
target/linux/ramips/base-files/etc/uci-defaults/02_network
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/dts/DCS-930.dts [new file with mode: 0644]
target/linux/ramips/image/Makefile
target/linux/ramips/rt305x/profiles/dlink.mk

index c8f73e79711930be880e35441af26437c9940184..bfe53e1d9e198e5a8c7a92964d64db67985c72d8 100755 (executable)
@@ -27,7 +27,7 @@ get_status_led() {
        d105)
                status_led="d105:red:power"
                ;;
-       dir-300-b1 | dir-600-b1 | dir-600-b2 | dir-610-a1 | dir-615-h1 | dir-615-d | dir-620-a1| dir-620-d1| dir-300-b7| dir-320-b1)
+       dcs-930 | dir-300-b1 | dir-600-b1 | dir-600-b2 | dir-610-a1 | dir-615-h1 | dir-615-d | dir-620-a1| dir-620-d1| dir-300-b7| dir-320-b1)
                status_led="d-link:green:status"
                ;;
        dir-645)
index a56781787de1c3d91adcf88e8c5a68ee736471f2..b0b071774a64cb17171e9aef84da011311462d4b 100644 (file)
@@ -68,6 +68,7 @@ case "$FIRMWARE" in
        br6524n | \
        carambola | \
        d105 | \
+       dcs-930 | \
        dir-300-b7 | \
        dir-320-b1 | \
        dir-610-a1 | \
index 0184ef4df7c138c2061f223985339d6b54e58460..345bd81a0b8f253c574400cdd3fc9e439bc9a6c6 100755 (executable)
@@ -43,6 +43,7 @@ ramips_setup_interfaces()
        all5003 | \
        awm002-evb | \
        broadway | \
+       dcs-930| \
        wnce2001)
                ucidef_add_switch "switch0" "1" "0"
                ucidef_set_interface_lan "eth0"
index a92e8189b9cce58fd613b102050a798553038bdb..494f9d4d0dc152262d1a7866d9bf1193d4cfd784 100755 (executable)
@@ -64,6 +64,9 @@ ramips_board_detect() {
        *"Aztech HW550-3G")
                name="hw550-3g"
                ;;
+       *"DCS-930")
+               name="dcs-930"
+               ;;
        *"DIR-300 B1")
                name="dir-300-b1"
                ;;
index cc8ca89aa58362ea043038886387d0db55cd97e8..e7087cc67351c34885e420a8ef8291f703691a75 100755 (executable)
@@ -29,6 +29,7 @@ platform_check_image() {
        broadway | \
        carambola | \
        d105 | \
+       dcs-930 | \
        dir-300-b1 | \
        dir-300-b7 | \
        dir-320-b1 | \
diff --git a/target/linux/ramips/dts/DCS-930.dts b/target/linux/ramips/dts/DCS-930.dts
new file mode 100644 (file)
index 0000000..31dab45
--- /dev/null
@@ -0,0 +1,118 @@
+/dts-v1/;
+
+/include/ "rt3050.dtsi"
+
+/ {
+       compatible = "DCS-930", "ralink,rt3050-soc";
+       model = "D-Link DCS-930";
+
+       pinctrl {
+               state_default: pinctrl0 {
+                       gpio {
+                               ralink,group = "i2c", "spi", "jtag", "mdio", "rgmii", "uartf";
+                               ralink,function = "gpio";
+                       };
+               };
+       };
+
+       cfi@1f000000 {
+               compatible = "cfi-flash";
+               reg = <0x1f000000 0x400000>;
+
+               bank-width = <2>;
+               device-width = <2>;
+               #address-cells = <1>;
+               #size-cells = <1>;
+
+               partition@0 {
+                       label = "u-boot";
+                       reg = <0x0 0x30000>;
+                       read-only;
+               };
+
+               partition@30000 {
+                       label = "u-boot-env";
+                       reg = <0x30000 0x10000>;
+                       read-only;
+               };
+
+               factory: partition@40000 {
+                       label = "factory";
+                       reg = <0x40000 0x10000>;
+                       read-only;
+               };
+
+               partition@50000 {
+                       label = "firmware";
+                       reg = <0x50000 0x3b0000>;
+               };
+       };
+
+       gpio-leds {
+               compatible = "gpio-leds";
+               wifi {
+                       label = "d-link:red:alert";
+                       gpios = <&gpio0 8 1>;
+               };
+               power {
+                       label = "d-link:green:status";
+                       gpios = <&gpio0 9 1>;
+               };
+               wps {
+                       label = "d-link:blue:wps";
+                       gpios = <&gpio0 13 1>;
+               };
+       };
+
+       gpio-keys-polled {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <20>;
+
+               wps {
+                       label = "wps";
+                       gpios = <&gpio0 0 1>;
+                       linux,code = <0x101>;
+               };
+               reset {
+                       label = "reset";
+                       gpios = <&gpio0 10 1>;
+                       linux,code = <0x198>;
+               };
+       };
+
+       esw@10110000 {
+               ralink,portmap = <0x2f>;
+
+               port@0 {
+                       compatible = "swconfig,port";
+                       swconfig,segment = "lan";
+                       swconfig,portmap = <0 4>;
+               };
+               port@1 {
+                       compatible = "swconfig,port";
+                       swconfig,segment = "lan";
+                       swconfig,portmap = <1 3>;
+               };
+               port@2 {
+                       compatible = "swconfig,port";
+                       swconfig,segment = "lan";
+                       swconfig,portmap = <2 2>;
+               };
+               port@3 {
+                       compatible = "swconfig,port";
+                       swconfig,segment = "lan";
+                       swconfig,portmap = <3 1>;
+               };
+               port@4 {
+                       compatible = "swconfig,port";
+                       swconfig,segment = "wan";
+                       swconfig,portmap = <4 0>;
+               };
+       };
+
+       otg@101c0000 {
+               status = "okay";
+       };
+};
index f4bb5686e8e56f9ad65ce797bab453326c7ed287..5ee76a6057c8509e0c2170a782c4b0aebadab757 100644 (file)
@@ -357,6 +357,8 @@ Image/Build/Profile/DAP1350=$(call BuildFirmware/dap1350/$(1),$(1),dap-1350,DAP-
 
 Image/Build/Profile/DAP1350WW=$(call BuildFirmware/dap1350/$(1),$(1),dap-1350WW,DAP-1350,RT3052-AP-DAP1350WW-3)
 
+Image/Build/Profile/DCS930=$(call BuildFirmware/Default4M/$(1),$(1),dcs-930,DCS-930)
+
 Image/Build/Profile/ESR-9753=$(call BuildFirmware/Default4M/$(1),$(1),esr-9753,ESR-9753)
 
 Image/Build/Profile/HW550-3G=$(call BuildFirmware/Default8M/$(1),$(1),hw550-3g,HW550-3G)
@@ -519,6 +521,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/DIR615H1,$(1))
        $(call Image/Build/Profile/DAP1350,$(1))
        $(call Image/Build/Profile/DAP1350WW,$(1))
+       $(call Image/Build/Profile/DCS930,$(1))
        $(call Image/Build/Profile/ESR-9753,$(1))
        $(call Image/Build/Profile/F7C027,$(1))
        $(call Image/Build/Profile/F5D8235V2,$(1))
index 877724d886581aa1424babd689bc9834009a0e8a..5c5ea8fc905f7ad102b26ffdf5252f7d75a5c353 100644 (file)
@@ -18,6 +18,18 @@ endef
 
 $(eval $(call Profile,DIR615H1))
 
+define Profile/DCS930
+       NAME:=Dlink DCS-930
+        PACKAGES:=kmod-video-core kmod-video-uvc \
+               kmod-usb-core kmod-usb-rt305x-dwc_otg
+endef
+
+define Profile/DCS930/Description
+       Package set for Dlink DCS-930 board
+endef
+
+$(eval $(call Profile,DCS930))
+
 define Profile/DIR610A1
        NAME:=Dlink DIR-610 A1
        PACKAGES:=kmod-ledtrig-netdev kmod-ledtrig-timer