package/grub: fix x86_64 issue (closes #7248)
authorAlexandros C. Couloumbis <alex@ozo.com>
Fri, 30 Apr 2010 07:07:20 +0000 (07:07 +0000)
committerAlexandros C. Couloumbis <alex@ozo.com>
Fri, 30 Apr 2010 07:07:20 +0000 (07:07 +0000)
SVN-Revision: 21264

package/grub/Makefile

index 9a50f820ec141a5271cc5ee1e8a2ee2e93a0fff8..20232f4954ba3f1adb64dd9470d2485203871ed3 100644 (file)
@@ -36,9 +36,12 @@ CONFIGURE_FLAGS:=
 ifneq ($(HOST_OS),Darwin)
 define Build/Configure
        (cd $(PKG_BUILD_DIR); \
+               CFLAGS="-march=i486 -m32" \
                LDFLAGS="-static" \
                ./configure \
                $(CONFIGURE_FLAGS) \
+               --build=i386-linux-gnu \
+               --host=i386-linux-gnu \
                --program-prefix="" \
                --program-suffix="" \
                --prefix=/usr \