tools: add back and update mm-macros, it is required for libsigc++
authorFelix Fietkau <nbd@openwrt.org>
Fri, 20 Mar 2015 11:34:47 +0000 (11:34 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 20 Mar 2015 11:34:47 +0000 (11:34 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 44905

tools/Makefile
tools/mm-macros/Makefile [new file with mode: 0644]

index 2d3197d696a6729e08cb79991da64227df9399ff..2dd0fbd6d0e8d1ff9ee99dc42f1cc7943aaf93e1 100644 (file)
@@ -27,7 +27,7 @@ tools-$(BUILD_TOOLCHAIN) += gmp mpfr mpc libelf
 tools-y += m4 libtool autoconf automake flex bison pkg-config sed mklibs
 tools-y += sstrip ipkg-utils genext2fs e2fsprogs mtd-utils mkimage
 tools-y += firmware-utils patch-image patch quilt yaffs2 flock padjffs2
-tools-y += missing-macros xz cmake scons bc findutils gengetopt patchelf
+tools-y += mm-macros missing-macros xz cmake scons bc findutils gengetopt patchelf
 tools-$(CONFIG_TARGET_orion_generic) += wrt350nv2-builder upslug2
 tools-$(CONFIG_powerpc) += upx
 tools-$(CONFIG_TARGET_x86) += qemu
@@ -59,6 +59,7 @@ $(curdir)/mkimage/compile := $(curdir)/sed/install
 $(curdir)/mklibs/compile := $(curdir)/libtool/install
 $(curdir)/qemu/compile := $(curdir)/e2fsprogs/install
 $(curdir)/upslug2/compile := $(curdir)/libtool/install
+$(curdir)/mm-macros/compile := $(curdir)/libtool/install
 $(curdir)/missing-macros/compile := $(curdir)/autoconf/install
 $(curdir)/e2fsprogs/compile := $(curdir)/libtool/install
 $(curdir)/libelf/compile := $(curdir)/libtool/install
diff --git a/tools/mm-macros/Makefile b/tools/mm-macros/Makefile
new file mode 100644 (file)
index 0000000..94ce0de
--- /dev/null
@@ -0,0 +1,31 @@
+#
+# Copyright (C) 2010-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=mm-macros
+PKG_VERSION:=0.9.7
+
+PKG_SOURCE_URL:=http://ftp.gnome.org/pub/GNOME/sources/mm-common/0.9
+PKG_SOURCE:=mm-common-$(PKG_VERSION).tar.xz
+PKG_MD5SUM:=a8b7c11db81a72168bf38d88d97df686
+
+HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/mm-common-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Host/Install
+       $(INSTALL_DIR) $(STAGING_DIR_HOST)/share/aclocal
+       $(INSTALL_DATA) $(HOST_BUILD_DIR)/macros/*.m4 $(STAGING_DIR_HOST)/share/aclocal/
+endef
+
+define Host/Clean
+       -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
+       $(call Host/Clean/Default)
+endef
+
+$(eval $(call HostBuild))