Revert "ncurses: cleanup InstallDev"
authorFelix Fietkau <nbd@openwrt.org>
Thu, 23 Apr 2015 11:06:15 +0000 (11:06 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Thu, 23 Apr 2015 11:06:15 +0000 (11:06 +0000)
This reverts r43204. The symlinks are faulty, as they point to a
temporary staging dir

Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 45569

package/libs/ncurses/Makefile

index 3e087f9497927ad9b5207ea03df668ea3e02cad9..13c7962dca72ef31b7529632616781c6bf11417a 100644 (file)
@@ -1,5 +1,5 @@
 #
 #
-# Copyright (C) 2006-2014 OpenWrt.org
+# Copyright (C) 2006-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -147,7 +147,7 @@ define Build/InstallDev
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/ncursesw5-config $(2)/bin/
        $(SED) 's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' -e 's/$$$$INCS //g' \
                $(2)/bin/ncursesw5-config
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/ncursesw5-config $(2)/bin/
        $(SED) 's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' -e 's/$$$$INCS //g' \
                $(2)/bin/ncursesw5-config
-       $(LN) $(2)/bin/ncursesw5-config $(1)/usr/bin/ncursesw5-config
+       ln -sf $(STAGING_DIR)/host/bin/ncursesw5-config $(1)/usr/bin/ncursesw5-config
 endef
 else
 define Build/InstallDev
 endef
 else
 define Build/InstallDev
@@ -161,7 +161,7 @@ define Build/InstallDev
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/ncurses5-config $(2)/bin/
        $(SED) 's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' \
                $(2)/bin/ncurses5-config
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/ncurses5-config $(2)/bin/
        $(SED) 's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' \
                $(2)/bin/ncurses5-config
-       $(LN) $(2)/bin/ncurses5-config $(1)/usr/bin/ncurses5-config
+       ln -sf $(STAGING_DIR)/host/bin/ncurses5-config $(1)/usr/bin/ncurses5-config
 endef
 endif
 
 endef
 endif