Added oidentd to buildroot-ng packages
authorGerry Rozema <groz@openwrt.org>
Fri, 21 Jul 2006 21:01:44 +0000 (21:01 +0000)
committerGerry Rozema <groz@openwrt.org>
Fri, 21 Jul 2006 21:01:44 +0000 (21:01 +0000)
SVN-Revision: 4199

net/oidentd/Makefile [new file with mode: 0755]
net/oidentd/files/S85oidentd [new file with mode: 0755]

diff --git a/net/oidentd/Makefile b/net/oidentd/Makefile
new file mode 100755 (executable)
index 0000000..41e90e3
--- /dev/null
@@ -0,0 +1,57 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id:$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=oidentd
+PKG_VERSION:=2.0.8
+PKG_RELEASE:=1
+PKG_MD5SUM:=c3d9a56255819ef8904b867284386911
+
+PKG_SOURCE_URL:=@SF/ojnk
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_CAT:=zcat
+
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/oidentd
+  SECTION:=net
+  CATEGORY:=Network
+  DEPENDS:=
+  TITLE:=Identd server 
+  DESCRIPTION:=A nat aware identd server that will correctly forwared requests to clients
+endef
+
+
+define Build/Configure
+$(call Build/Configure/Default,--includedir=$(PKG_BUILD_DIR)/)
+endef
+
+define Build/Compile
+       rm -rf $(PKG_INSTALL_DIR)
+       mkdir -p $(PKG_INSTALL_DIR)
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               CC=$(TARGET_CC)
+       $(STRIP) $(PKG_BUILD_DIR)/src/$(PKG_NAME)
+endef
+
+define Package/oidentd/install
+       install -m0755 -d $(1)/usr/sbin
+       install -m0755 -d $(1)/etc/init.d
+       $(CP) $(PKG_BUILD_DIR)/src/$(PKG_NAME) $(1)/usr/sbin/
+       $(CP) ./files/S85oidentd $(1)/etc/init.d
+endef
+
+$(eval $(call BuildPackage,oidentd))
+
+
+
diff --git a/net/oidentd/files/S85oidentd b/net/oidentd/files/S85oidentd
new file mode 100755 (executable)
index 0000000..6f3e05d
--- /dev/null
@@ -0,0 +1,3 @@
+#!/bin/sh
+/usr/sbin/oidentd -m -f 113
+