[include/kernel-defaults.mk] enable verbose output of kernel build if V=99 is passed
authorMirko Vogt <mirko@openwrt.org>
Tue, 24 Apr 2012 12:42:57 +0000 (12:42 +0000)
committerMirko Vogt <mirko@openwrt.org>
Tue, 24 Apr 2012 12:42:57 +0000 (12:42 +0000)
append V=1 to KERNEL_MAKEOPTS when $V (and therewith $KBUILD_VERBOSE) is set to 99

SVN-Revision: 31466

include/kernel-defaults.mk

index 9a1dace3e6951f9846b96f85f487d821ef70c87e..6864793a271c33feae393a5f31ebc6a4268cf55b 100644 (file)
@@ -22,6 +22,10 @@ ifneq (,$(KERNEL_CC))
   KERNEL_MAKEOPTS += CC="$(KERNEL_CC)"
 endif
 
+ifeq ($(KBUILD_VERBOSE),99)
+  KERNEL_MAKEOPTS += V=1
+endif
+
 export HOST_EXTRACFLAGS=-I$(STAGING_DIR_HOST)/include
 
 # defined in quilt.mk