libssh: moved to github
authorSteven Barth <cyrus@openwrt.org>
Thu, 17 Jul 2014 20:28:30 +0000 (20:28 +0000)
committerSteven Barth <cyrus@openwrt.org>
Thu, 17 Jul 2014 20:28:30 +0000 (20:28 +0000)
SVN-Revision: 41705

libs/libssh2/Makefile [deleted file]

diff --git a/libs/libssh2/Makefile b/libs/libssh2/Makefile
deleted file mode 100644 (file)
index 4410cd3..0000000
+++ /dev/null
@@ -1,54 +0,0 @@
-#
-# Copyright (C) 2012 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=libssh2
-PKG_VERSION:=1.4.3
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.libssh2.org/download
-PKG_MD5SUM:=071004c60c5d6f90354ad1b701013a0b
-
-PKG_INSTALL:=1
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/libssh2
-  SECTION:=libs
-  CATEGORY:=Libraries
-  TITLE:=SSH2 library
-  URL:=http://www.libssh2.org/
-  DEPENDS:=+libopenssl +zlib
-endef
-
-define Package/libssh2/description
- libssh2 is a client-side C library implementing the SSH2 protocol.
-endef
-
-TARGET_CFLAGS += $(FPIC)
-
-CONFIGURE_ARGS += \
-       --disable-examples-build \
-       --with-libssl-prefix=$(STAGING_DIR)/usr
-
-define Build/InstallDev
-       $(INSTALL_DIR) $(1)/usr/include
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/*.h $(1)/usr/include/
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libssh2.so* $(1)/usr/lib/
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libssh2.pc $(1)/usr/lib/pkgconfig/
-endef
-
-define Package/libssh2/install
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libssh2.so* $(1)/usr/lib/
-endef
-
-$(eval $(call BuildPackage,libssh2))