madwifi: fix a header file conflict with iptables
authorFelix Fietkau <nbd@openwrt.org>
Thu, 23 Apr 2009 14:55:11 +0000 (14:55 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Thu, 23 Apr 2009 14:55:11 +0000 (14:55 +0000)
SVN-Revision: 15354

package/madwifi/Makefile
package/wprobe/Makefile

index 433cb61e15bbbfb6eb89a16a64a399bf8158cee6..cfa9f44f4923effde268a160e3c169eaae9d1bcb 100644 (file)
@@ -176,7 +176,7 @@ MADWIFI_INC = \
        -I$(PKG_BUILD_DIR)/ath \
        -I$(PKG_BUILD_DIR)/ath_hal \
        -I$(PKG_BUILD_DIR)/net80211 \
        -I$(PKG_BUILD_DIR)/ath \
        -I$(PKG_BUILD_DIR)/ath_hal \
        -I$(PKG_BUILD_DIR)/net80211 \
-       -I$(STAGING_DIR)/usr/include \
+       -I$(STAGING_DIR)/usr/include/wprobe \
        -include $(PKG_BUILD_DIR)/include/compat.h
 
 MAKE_ARGS:= \
        -include $(PKG_BUILD_DIR)/include/compat.h
 
 MAKE_ARGS:= \
index 69c450767089aff9678e898a50018d30f29573af..bbc2b88c94aff5050235650f9c85c66ed6ae3dbf 100644 (file)
@@ -103,8 +103,8 @@ define Build/Compile
 endef
 
 define Build/InstallDev
 endef
 
 define Build/InstallDev
-       $(INSTALL_DIR) $(1)/usr/include
-       $(CP) $(PKG_BUILD_DIR)/kernel/linux $(1)/usr/include
+       $(INSTALL_DIR) $(1)/usr/include/wprobe
+       $(CP) $(PKG_BUILD_DIR)/kernel/linux $(1)/usr/include/wprobe
 endef
 
 define Package/wprobe-info/install
 endef
 
 define Package/wprobe-info/install