kernel: kmod-udptunnel6 depends on IPv6
authorJo-Philipp Wich <jow@openwrt.org>
Mon, 16 Nov 2015 17:39:32 +0000 (17:39 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Mon, 16 Nov 2015 17:39:32 +0000 (17:39 +0000)
Spotted a missing 'ip6_udp_tunnel.ko' build failure during a local
build with all kmods enabled but globally disabled IPv6 support.

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
SVN-Revision: 47487

package/kernel/linux/modules/netsupport.mk

index b81d9b4e44868954e01e9938a84059e7647230f1..66c6617d99004c0517805f0d8d250b75f66cac6d 100644 (file)
@@ -159,6 +159,7 @@ $(eval $(call KernelPackage,udptunnel4))
 define KernelPackage/udptunnel6
   SUBMENU:=$(NETWORK_SUPPORT_MENU)
   TITLE:=IPv6 UDP tunneling support
+  DEPENDS:=@IPV6
   KCONFIG:=CONFIG_NET_UDP_TUNNEL
   FILES:=$(LINUX_DIR)/net/ipv6/ip6_udp_tunnel.ko
   AUTOLOAD:=$(call AutoLoad,32,ip6_udp_tunnel)