[packages] quagga: use PKG_INSTALL
authorNicolas Thill <nico@openwrt.org>
Tue, 3 Aug 2010 12:04:11 +0000 (12:04 +0000)
committerNicolas Thill <nico@openwrt.org>
Tue, 3 Aug 2010 12:04:11 +0000 (12:04 +0000)
SVN-Revision: 22472

net/quagga/Makefile

index 75fad9bcce7eb5f5283cb3351f3e1b50b4fb31b0..a2bf9637900f29a5276e48e60fc5b87a5bf78e65 100644 (file)
@@ -23,6 +23,7 @@ PKG_CONFIG_DEPENDS:= \
        CONFIG_PACKAGE_quagga-unstable-ripngd
 
 PKG_FIXUP:=libtool
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -144,12 +145,6 @@ ifneq ($(CONFIG_PACKAGE_quagga-ripngd),)
   CONFIGURE_ARGS+= --enable-ripngd
 endif
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR=$(PKG_INSTALL_DIR) \
-               all install
-endef
-
 define Package/quagga/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/zebra $(1)/usr/sbin/