peerguardian fixes: add dependency on queue netfilter module, run the actual daemon...
authorNicolas Thill <nico@openwrt.org>
Sat, 29 Sep 2007 18:37:34 +0000 (18:37 +0000)
committerNicolas Thill <nico@openwrt.org>
Sat, 29 Sep 2007 18:37:34 +0000 (18:37 +0000)
SVN-Revision: 9072

net/peerguardian/Makefile
net/peerguardian/files/peerguardian.init [changed mode: 0644->0755]

index 9020052a852114d9dbd0ad23d29c7eca0a71c653..f184dcfd7e065dfbb209356ffeb290fb774214ae 100644 (file)
@@ -15,7 +15,6 @@ PKG_RELEASE:=1
 PKG_SOURCE:=pglinux-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/peerguardian
 PKG_MD5SUM:=0fb2bc5501b031604fc56eec3bd35fa4
-PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/pglinux-$(PKG_VERSION)
 
@@ -26,14 +25,16 @@ include $(INCLUDE_DIR)/package.mk
 define Package/peerguardian
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:= +libncurses +libpthread +uclibcxx
+  DEPENDS:= +kmod-ipt-queue +libncurses +libpthread +uclibcxx
   TITLE:=PeerGuardian for Linux
-  DESCRIPTION:=\
-       PeerGuardian helps protect your privacy by blocking many ranges \\\
-       of aggressive IPs while you use P2P.
   URL:=http://phoenixlabs.org/
 endef
 
+define Package/peerguardian/description
+ PeerGuardian helps protect your privacy by blocking many ranges  of aggressive 
+ IPs while you use P2P.
+endef
+
 define Package/peerguardian/conffiles
 /etc/PG.conf
 /etc/p2p.p2b.p2p
old mode 100644 (file)
new mode 100755 (executable)
index 3da3aa4..c0cb8be
@@ -2,16 +2,11 @@
 # Copyright (C) 2006 OpenWrt.org
 START=50
 
-BIN=pgtext
-DEFAULT=/etc/default/$BIN
-RUN_D=/var/run
-PID_F=$RUN_D/$BIN_${IF}_${ID}.pid
+BIN=peerguardnf
+CFG_F=/etc/PG.conf
+OPTIONS="-c $CFG_F -d"
 
 start() {
-       [ -f $DEFAULT ] && . $DEFAULT
        $BIN $OPTIONS
 }
 
-stop() {
-       [ -f $PID_F ] && kill $(cat $PID_F) >/dev/null 2>&1
-}