package/grub: add a prereq check for 32 bits host development files when building...
authorNicolas Thill <nico@openwrt.org>
Mon, 16 Aug 2010 09:12:46 +0000 (09:12 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 16 Aug 2010 09:12:46 +0000 (09:12 +0000)
SVN-Revision: 22667

package/grub/Makefile

index 5fd2a230883e292b437bf640801ac15844f2b4c7..426b9c367307fc5ede8d1dad88f80bb420ea5e1e 100644 (file)
@@ -88,5 +88,16 @@ define Package/grub/install
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/* $(1)/usr/sbin/
 endef
 
+ifeq ($(HOST_ARCH),x86_64)
+  define Require/working-gcc-m32
+       echo 'int main(int argc, char **argv) { return 0; }' | \
+               gcc -x c -o $(TMP_DIR)/a.out - -m32 -lc
+  endef
+endif
+
+$(eval $(call Require,working-gcc-m32, \
+       Please install 32 bits development files. (gcc-multilib on Debian/Ubuntu, gcc.i686 and libgcc.i686 on CentOS/Fedora/RHEL) \
+))
+
 $(eval $(call HostBuild))
 $(eval $(call BuildPackage,grub))