Add image generation for ar525w
authorFlorian Fainelli <florian@openwrt.org>
Tue, 19 Dec 2006 23:48:47 +0000 (23:48 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Tue, 19 Dec 2006 23:48:47 +0000 (23:48 +0000)
SVN-Revision: 5868

target/linux/rdc-2.6/image/Makefile

index 06082404ee7c6aeca838d8e66e93ea162a17b1c0..d71c1988401db6b425815f7e973215c999f3130b 100644 (file)
@@ -13,13 +13,9 @@ endef
 define Image/Prepare
 endef
 
 define Image/Prepare
 endef
 
-define Image/Prepare
-        cat $(KDIR)/vmlinux | $(STAGING_DIR)/bin/lzma e -si -so -eos -lc1 -lp2 -pb2 > $(KDIR)/vmlinux.lzma
-endef
-
-define Image/Build/ar525w
+define Image/Build
+       touch $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img
+       $(STAGING_DIR)/bin/airlink -b 1 -j $(LINUX_DIR)/arch/i386/boot/bzImage $(KDIR)/root.$(1) $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img
 endef
 
 endef
 
-$(call Image/Build/ar525w,$(1),$(patsubst jffs2-%,jffs2,$(1)))
-
 $(eval $(call BuildImage))
 $(eval $(call BuildImage))