firewall3: update to git head
authorJo-Philipp Wich <jow@openwrt.org>
Fri, 8 Mar 2013 15:27:33 +0000 (15:27 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Fri, 8 Mar 2013 15:27:33 +0000 (15:27 +0000)
- introduce per-zone user chains
- support legacy "tcpudp" protocol notation

SVN-Revision: 35903

package/network/config/firewall3/Makefile
package/network/config/firewall3/files/firewall.user

index cd9405eae44a6bcd2a9eb2172ea51b8d04853306..e29f614637f115a587f1b2b6ed4f887f1f697d74 100644 (file)
@@ -8,13 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=firewall3
-PKG_VERSION:=2013-03-02
+PKG_VERSION:=2013-03-08
 PKG_RELEASE:=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=git://nbd.name/firewall3.git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=46536e5263c4bf57a91c38b5d08d78c774649dda
+PKG_SOURCE_VERSION:=b2b2e69b19a20a46f3db6d717a899248fa24628c
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
 PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
 
index 1ccbd01657422cd24fe2742755065b954e95a6bd..6f799063f5a1940c481f9e31405f7bfc0491f097 100644 (file)
@@ -2,3 +2,6 @@
 # Put your custom iptables rules here, they will
 # be executed with each firewall (re-)start.
 
+# Internal uci firewall chains are flushed and recreated on reload, so
+# put custom rules into the root chains e.g. INPUT or FORWARD or into the
+# special user chains, e.g. input_wan_rule or postrouting_lan_rule.