[packages] libsigc++: update to 2.2.8 (#8276), thanks sav, use PKG_INSTALL and refres...
authorStephen Walker <stephendwalker@gmail.com>
Fri, 17 Dec 2010 04:33:19 +0000 (04:33 +0000)
committerStephen Walker <stephendwalker@gmail.com>
Fri, 17 Dec 2010 04:33:19 +0000 (04:33 +0000)
SVN-Revision: 24635

libs/libsigc++/Makefile
libs/libsigc++/patches/001-no_doc_tests_examples.patch

index f68bd8d93b44624bce0f7886b17c65ddde498ba0..45d101ce7a0665e2b64d0da3c06228015bbbd7d8 100644 (file)
@@ -1,4 +1,4 @@
-# 
+#
 # Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -8,14 +8,15 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libsigc++
-PKG_VERSION:=2.2.6
+PKG_VERSION:=2.2.8
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@GNOME/libsigc++/2.2
-PKG_MD5SUM:=d216ef85785e0d17eda9b0326cfdcf71
+PKG_MD5SUM:=1198425eab9fd605721a278c651b8dd8
 
-PKG_FIXUP = libtool
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -42,12 +43,6 @@ CONFIGURE_ARGS += \
        --enable-shared \
        --enable-static \
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
-
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/sigc++-2.0 $(1)/usr/include/
@@ -64,4 +59,3 @@ define Package/libsigcxx/install
 endef
 
 $(eval $(call BuildPackage,libsigcxx))
-
index c2e87da3503546e4ecc86c86f6439a93abe4a83b..fbfb3bbf3f72e5552024fab1c4a2ea75144b86f5 100644 (file)
@@ -1,7 +1,6 @@
-diff -urN libsigc++-2.2.3/Makefile.am libsigc++-2.2.3.new/Makefile.am
---- a/Makefile.am      2009-08-20 14:32:40.000000000 +0400
-+++ b/Makefile.am      2009-11-13 10:26:01.000000000 +0300
-@@ -22,7 +22,7 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -22,7 +22,7 @@ doc_subdirs = docs
  else
  doc_subdirs =
  endif
@@ -10,11 +9,10 @@ diff -urN libsigc++-2.2.3/Makefile.am libsigc++-2.2.3.new/Makefile.am
  
  sigc_configdir = $(libdir)/$(SIGCXX_MODULE_NAME)/include
  nodist_sigc_config_HEADERS = sigc++config.h
-diff -urN libsigc++-2.2.3/Makefile.in libsigc++-2.2.3.new/Makefile.in
---- a/Makefile.in      2009-09-02 19:55:19.000000000 +0400
-+++ b/Makefile.in      2009-11-13 10:29:43.000000000 +0300
-@@ -89,7 +89,7 @@
-   distclean-recursive maintainer-clean-recursive
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -114,7 +114,7 @@ AM_RECURSIVE_TARGETS = $(RECURSIVE_TARGE
+       distdir dist dist-all distcheck
  ETAGS = etags
  CTAGS = ctags
 -DIST_SUBDIRS = sigc++ tests examples docs