kernel: update to linux 4.1.3
authorFelix Fietkau <nbd@openwrt.org>
Wed, 22 Jul 2015 12:45:07 +0000 (12:45 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Wed, 22 Jul 2015 12:45:07 +0000 (12:45 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 46437

include/kernel-version.mk
target/linux/ar71xx/patches-4.1/910-unaligned_access_hacks.patch
target/linux/generic/patches-4.1/259-regmap_dynamic.patch
target/linux/generic/patches-4.1/810-pci_disable_common_quirks.patch
target/linux/generic/patches-4.1/921-use_preinit_as_init.patch

index 3aac242079318bf1fc460eed9a458acb684586b8..e0b98267c69ed781787243070ddcd82d8906e947 100644 (file)
@@ -4,11 +4,11 @@ LINUX_RELEASE?=1
 
 LINUX_VERSION-3.18 = .18
 LINUX_VERSION-4.0 = .8
-LINUX_VERSION-4.1 = .2
+LINUX_VERSION-4.1 = .3
 
 LINUX_KERNEL_MD5SUM-3.18.18 = 6fce868a56f2d83f80cdad5fed457110
 LINUX_KERNEL_MD5SUM-4.0.8 = a99375dd855de00635e9ac8e62b0f8e6
-LINUX_KERNEL_MD5SUM-4.1.2 = 26879db288cd9ffa17c9fd5db213b272
+LINUX_KERNEL_MD5SUM-4.1.3 = 96c2c77b1c54ba01cfd8fc2d13fbf828
 
 ifdef KERNEL_PATCHVER
   LINUX_VERSION:=$(KERNEL_PATCHVER)$(strip $(LINUX_VERSION-$(KERNEL_PATCHVER)))
index 05f6465f371c6fb10a931edc0275608d5da1f9f7..3a73aea431b450df73c0ac7d5dddb524359529f1 100644 (file)
                                 IPSTATS_MIB_INHDRERRORS);
 --- a/include/linux/types.h
 +++ b/include/linux/types.h
-@@ -207,5 +207,11 @@ struct callback_head {
+@@ -215,5 +215,11 @@ struct callback_head {
  /* clocksource cycle base type */
  typedef u64 cycle_t;
  
index 33ca2f65c9886a389960046c530a54b5ed0a5ad9..def9ace7ff4184e53ac88d7927bdd1b4aadfdf5e 100644 (file)
@@ -78,7 +78,7 @@
  #include <linux/mutex.h>
  #include <linux/err.h>
  #include <linux/of.h>
-@@ -2632,3 +2633,5 @@ static int __init regmap_initcall(void)
+@@ -2631,3 +2632,5 @@ static int __init regmap_initcall(void)
        return 0;
  }
  postcore_initcall(regmap_initcall);
index eee15517e0318a789773ea38cc1a3e61deb3f179..8f72637eecc7058d527be70e375960ee8d517fd4 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/pci/Kconfig
 +++ b/drivers/pci/Kconfig
-@@ -64,6 +64,12 @@ config XEN_PCIDEV_FRONTEND
+@@ -68,6 +68,12 @@ config XEN_PCIDEV_FRONTEND
            The PCI device frontend driver allows the kernel to import arbitrary
            PCI devices from a PCI backend to support PCI driver domains.
  
index d3055354e26dea3aad6d9e060d10420ada3aabf8..73da5b3a546ba9dd2af6991e494c59a0e7364f40 100644 (file)
@@ -1,6 +1,6 @@
 --- a/init/main.c
 +++ b/init/main.c
-@@ -959,7 +959,8 @@ static int __ref kernel_init(void *unuse
+@@ -960,7 +960,8 @@ static int __ref kernel_init(void *unuse
                panic("Requested init %s failed (error %d).",
                      execute_command, ret);
        }