fix dependency order for sstrip
authorMike Baker <mbm@openwrt.org>
Fri, 20 Aug 2004 22:02:15 +0000 (22:02 +0000)
committerMike Baker <mbm@openwrt.org>
Fri, 20 Aug 2004 22:02:15 +0000 (22:02 +0000)
SVN-Revision: 144

obsolete-buildroot/make/openwrt.mk
obsolete-buildroot/make/squashfsroot.mk

index b8c2c9636e7ee018616f62d0ce5599089bb67d49..38fa9587588a039f1a6a669c557e26d1ded0438a 100644 (file)
@@ -202,8 +202,7 @@ openwrt-rootprep:
 
 ######################################################################
 
-openwrt-prune: $(STAGING_DIR)/bin/sstrip openwrt-base
-#      -find $(TARGET_DIR) -type f -perm +111 -exec $(STAGING_DIR)/bin/sstrip {} \;
+openwrt-prune: openwrt-base $(STAGING_DIR)/bin/sstrip
        # remove unneeded uClibc libs
        rm -rf $(TARGET_DIR)/lib/libthread_db*
        rm -rf $(TARGET_DIR)/lib/libpthread*
@@ -214,6 +213,7 @@ openwrt-prune: $(STAGING_DIR)/bin/sstrip openwrt-base
        rm -f $(TARGET_DIR)/usr/sbin/iptables-save
        rm -f $(TARGET_DIR)/usr/sbin/iptables-restore
        rm -f $(TARGET_DIR)/usr/sbin/ip6tables
+       -@find $(TARGET_DIR) -type f -perm +111 | xargs $(STAGING_DIR)/bin/sstrip 2>/dev/null || true;
 
 ######################################################################
 
index 3e1b34a834e2a9f110cfd1f2bb290655bd84d994..6c66982e297b46fa87f9252a2e49a53f193b7607 100644 (file)
@@ -36,7 +36,7 @@ squashfs-dirclean:
 
 squashfsroot: squashfs
        #-@find $(TARGET_DIR)/lib -type f -name \*.so\* | xargs $(STRIP) --strip-unneeded 2>/dev/null || true;
-       -@find $(TARGET_DIR) -type f -perm +111 | xargs $(STAGING_DIR)/bin/sstrip 2>/dev/null || true;
+       #-@find $(TARGET_DIR) -type f -perm +111 | xargs $(STAGING_DIR)/bin/sstrip 2>/dev/null || true;
        @rm -rf $(TARGET_DIR)/usr/man
        @rm -rf $(TARGET_DIR)/usr/info
        #$(SQUASHFS_DIR)/squashfs-tools/mksquashfs -q -D $(SOURCE_DIR)/device_table.txt $(TARGET_DIR) $(IMAGE)