Add uucp
authorFlorian Fainelli <florian@openwrt.org>
Sat, 15 Nov 2008 12:29:38 +0000 (12:29 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 15 Nov 2008 12:29:38 +0000 (12:29 +0000)
SVN-Revision: 13216

net/uucp/Makefile [new file with mode: 0644]

diff --git a/net/uucp/Makefile b/net/uucp/Makefile
new file mode 100644 (file)
index 0000000..9255da6
--- /dev/null
@@ -0,0 +1,50 @@
+# 
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id: $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=uucp
+PKG_VERSION:=1.07
+
+PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
+PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/main/u/uucp/
+PKG_MD5SUM:=
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/uucp
+  SECTION:=net
+  CATEGORY:=Network
+  TITLE:=copy files to or from another (usually *nix) system
+  URL:=http://packages.debian.org/etch/uucp
+endef
+
+define Package/uucp/description
+       UUCP is used to transfer mail, news and random files between systems which are not
+       connected by more modern networks. The communication can be made via modems, direct
+       (hard-wired) serial connections or via an IP connection.
+endef
+
+CONFIGURE_ARGS += \
+       --enable-static \
+       --enable-shared
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               all install
+endef
+
+
+define Package/uucp/install
+       $(INSTALL_DIR) $(1)/usr/bin/
+       $(CP) $(PKG_BUILD_DIR)/{cu,tstuu,uu{chk,cico,conv,cp,log,name,pick,sched,stat,to,x,xqt}} $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,uucp))