add NTFS-3G
authorImre Kaloz <kaloz@openwrt.org>
Thu, 8 Feb 2007 17:34:08 +0000 (17:34 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Thu, 8 Feb 2007 17:34:08 +0000 (17:34 +0000)
SVN-Revision: 6279

package/ntfs-3g/Makefile [new file with mode: 0644]
package/ntfs-3g/patches/100-no_ldconfig.patch [new file with mode: 0644]

diff --git a/package/ntfs-3g/Makefile b/package/ntfs-3g/Makefile
new file mode 100644 (file)
index 0000000..314a52c
--- /dev/null
@@ -0,0 +1,111 @@
+# 
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
+
+PKG_NAME:=ntfs-3g
+PKG_VERSION:=0.20070207-RC1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
+PKG_SOURCE_URL:=http://www.ntfs-3g.org/
+PKG_MD5SUM:=7c8c7a1338a0d36e315b665422e04c46
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+PKG_BUILD_DEPENDS:=libfuse
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/ntfs-3g
+  TITLE:=NTFS-3G
+  DEPENDS:=+libfuse +fuse-utils
+  SECTION:=utils
+  CATEGORY:=Utilities
+  DESCRIPTION:=\
+       Third generation Read/Write NTFS driver
+  URL:=http://www.ntfs-3g.org
+endef
+
+define Build/Configure
+       (cd $(PKG_BUILD_DIR); rm -f config.cache; \
+               touch configure.in ; \
+               touch aclocal.m4 ; \
+               touch Makefile.in ; \
+               touch include/config.h.in ; \
+               touch configure ; \
+               $(TARGET_CONFIGURE_OPTS) \
+               PKG_CONFIG_PATH="$(STAGING_DIR)/usr/lib/pkgconfig" \
+               PKG_CONFIG_LIBDIR="$(STAGING_DIR)/usr/lib/pkgconfig" \
+               CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
+               ./configure \
+                       --target=$(GNU_TARGET_NAME) \
+                       --host=$(GNU_TARGET_NAME) \
+                       --build=$(GNU_HOST_NAME) \
+                       --program-prefix="" \
+                       --program-suffix="" \
+                       --prefix=/usr \
+                       --exec-prefix=/usr \
+                       --bindir=/usr/bin \
+                       --datadir=/usr/share \
+                       --includedir=/usr/include \
+                       --infodir=/usr/share/info \
+                       --libdir=/usr/lib \
+                       --libexecdir=/usr/lib \
+                       --localstatedir=/var \
+                       --mandir=/usr/share/man \
+                       --sbindir=/usr/sbin \
+                       --sysconfdir=/etc \
+                       $(DISABLE_LARGEFILE) \
+                       $(DISABLE_NLS) \
+                       --enable-shared \
+                       --enable-static \
+                       --disable-rpath \
+                       --enable-kernel-module \
+                       --enable-lib \
+                       --enable-util \
+                       --disable-example \
+                       --disable-auto-modprobe \
+                       --with-kernel="$(LINUX_DIR)" \
+                       --disable-mtab \
+       );
+endef
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               ARCH="$(LINUX_KARCH)" \
+               CROSS_COMPILE="$(TARGET_CROSS)" \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               all install
+endef
+
+define Build/InstallDev
+       mkdir -p $(STAGING_DIR)/usr/include
+       $(CP)   $(PKG_INSTALL_DIR)/usr/include/ntfs-3g $(STAGING_DIR)/usr/include/
+       mkdir -p $(STAGING_DIR)/usr/lib
+       $(CP)   $(PKG_INSTALL_DIR)/usr/lib/libntfs-3g.{a,so*} $(STAGING_DIR)/usr/lib/
+endef
+
+define Build/UninstallDev
+       rm -rf  $(STAGING_DIR)/usr/include/ntfs-3g \
+               $(STAGING_DIR)/usr/lib/libntfs-3g.{a,so*}
+endef
+
+define Package/ntfs-3g/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/ntfs-3g $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libntfs-3g.so.* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,ntfs-3g))
diff --git a/package/ntfs-3g/patches/100-no_ldconfig.patch b/package/ntfs-3g/patches/100-no_ldconfig.patch
new file mode 100644 (file)
index 0000000..c64db73
--- /dev/null
@@ -0,0 +1,12 @@
+diff -Nur ntfs-3g-0.20070207-RC1/src/Makefile.in ntfs-3g-0.20070207-RC1-owrt/src/Makefile.in
+--- ntfs-3g-0.20070207-RC1/src/Makefile.in     2007-02-06 22:43:10.000000000 +0100
++++ ntfs-3g-0.20070207-RC1-owrt/src/Makefile.in        2007-02-08 12:54:27.000000000 +0100
+@@ -582,7 +582,7 @@
+ install-exec-hook:
+       $(INSTALL) -d $(DESTDIR)/sbin
+       $(LN_S) -f $(bindir)/ntfs-3g $(DESTDIR)/sbin/mount.ntfs-3g
+-      $(LDCONFIG)
++#     $(LDCONFIG)
+ install-data-hook:
+       $(INSTALL) -d $(DESTDIR)$(man8dir)