[package] add XTS cipher CryptoAPI module
authorFlorian Fainelli <florian@openwrt.org>
Sat, 4 Sep 2010 18:06:24 +0000 (18:06 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 4 Sep 2010 18:06:24 +0000 (18:06 +0000)
needed for proper dm-crypt support

Signed-off-by: Jan Willies <jan@willies.info>
SVN-Revision: 22915

package/kernel/modules/crypto.mk

index fa2ddbc2117ab8106bc749c80753a4649544f3bb..421e37fa710ce3537e3ead51304fe6367bf2329a 100644 (file)
@@ -356,3 +356,20 @@ endef
 
 $(eval $(call KernelPackage,crypto-test))
 
 
 $(eval $(call KernelPackage,crypto-test))
 
+
+define KernelPackage/crypto-xts
+  TITLE:=XTS cipher CryptoAPI module
+  KCONFIG:= \
+       CONFIG_CRYPTO_GF128MUL \
+       CONFIG_CRYPTO_XTS
+  FILES:= \
+       $(LINUX_DIR)/crypto/xts.ko \
+       $(LINUX_DIR)/crypto/gf128mul.ko
+  AUTOLOAD:=$(call AutoLoad,09, \
+       gf128mul \
+       xts \
+  )
+  $(call AddDepends/crypto)
+endef
+
+$(eval $(call KernelPackage,crypto-xts))